Combinedfit failure

I re-installed windows and root and when I tried the tutorial below, the programm stops.
Any idea why?

C:\Program Files (x86)\Microsoft Visual Studio 14.0>root
  *                                         *
  *        W E L C O M E  to  R O O T       *
  *                                         *
  *   Version   5.34/34    2 October 2015   *
  *                                         *
  *  You are welcome to visit our Web site  *
  *            *
  *                                         *

ROOT 5.34/34 (v5-34-34@v5-34-34, Oct 02 2015, 16:30:37 on win32)

CINT/ROOT C/C++ Interpreter version 5.18.00, July 2, 2010
Type ? for help. Commands must be C++ statements.
Enclose multiple statements between { }.
root [0] .x $ROOTSYS/tutorials/fit/combinedFit.C+

Minimizer is Minuit2 / Migrad


Which version of ROOT did you install? How does it stops? Do you have any error message?
Could you try with “.x $ROOTSYS/tutorials/fit/combinedFit.C++”?
For example, ROOT v5.34 works fine for me:

[code]root [0] .x $ROOTSYS/tutorials/fit/combinedFit.C+
Info in TWinNTSystem::ACLiC: creating shared library C:\Users\bellenot\bin\roo
Creating library C:\Users\bellenot\bin\root\v5-34-00-patches/tutorials/fit\co
mbinedFit_C.lib and object C:\Users\bellenot\bin\root\v5-34-00-patches/tutorials

Minimizer is Minuit2 / Migrad
Chi2 = 131.104
NDf = 115
Edm = 2.11602e-008
NCalls = 225
Par_0 = 5.5396 +/- 0.0354094
Par_1 = 4.66089 +/- 0.050106
Par_2 = -0.0514037 +/- 0.00108539 (limited)
Par_3 = 77.2733 +/- 3.93105 (limited)
Par_4 = 30 (fixed)
Par_5 = 4.864 +/- 0.243005
root [1]

[color=#FF0000]EDIT:[/color] BTW, don’t start ROOT from “C:\Program Files (x86)\Microsoft Visual Studio 14.0”
[color=#FF0000]EDIT(2)[/color] And BTW, ROOT is NOT compatible with Visual Studio 2015…

Cheers, Bertrand.


I use the same version 5.34 --see the screenshot.

I tried the .x $ROOTSYS/tutorials/fit/combinedFit.C++ and it crashes again. beside the error message in the root window, there is a popup screen which is saying "root.exe has stopped working: A problem causes the program to stop working correctly…Please close the program " and there are two options Close the program , Debug the program

EDIT(2) And BTW, ROOT is NOT compatible with Visual Studio 2015….
Should I downgrade to 2013?

EDIT: BTW, don’t start ROOT from "C:\Program Files (x86)\Microsoft Visual Studio 14.0"
I thought this is the recommended way to start from “Administrator: Developer Command Prompt” console.


Hi Sorina,

Yes. You must use a version of ROOT built with the exact same version of Visual Studio (this is not specific to ROOT). I.e. you cannot mix different versions of Visual Studio.

Well, it could work, but the safe way is to start from a location without spaces and where you can write… And BTW, recommended by who?

Cheers, Bertrand.