Clxx: fatal error C1356: 无法找到 mspdbcore.h

ROOT Version: 6.14/04
Platform: Windows 10
Compiler: VS2017 Community

When I follow the example of A ROOT Guide For Beginners at 3.4.1 Compile a Macro with ACLiC,I run the code “.L macro1.C+”, the file macro1.C+ is in my current file path. The error occured.

I try to copy mspdbcore.dll from directory C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE to directory C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.15.26726\bin\Hostx64\x86 , where cl.exe in. But it doesn’t work as well. By the way, it can’t find the cl at the beginning, so I add the directory of cl.exe (which is C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.15.26726\bin\Hostx64\x86) to the ENVIRONMENT PATH, it works, then the above error occured!
Besides, gibberish appears on the dos tty, how can I fix it?
Would you help me? thanks advanced!


To use ACLiC, you must start ROOT from a x86 Native Tools Command Prompt for VS 2017

Cheers, Bertrand.

Thanks a lot, the problem solved use Native Tools Command Prompt for VS 2017. However, a new problem accures!

I know, a bug report has been opened at Microsoft. You can even vote for it if you want :wink:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.