Home | News | Documentation | Download

Caught an Interpreter exception in windows

Hi All,

When i tried adding #include in cling prompt. I am getting Caught an Interpreter exception!!!
ELF COMDATs only support SelectionKind::Any, ‘??_7_Generic_error_category@std@@6b@’ cannot be lowered.

Same error also seen when i executed cout<<“test”;

Please let me know how to fix it.

Thanks and Regards,
Muthu

Hi Muthu,

We’ll have to debug it. But FYI, cling is not yet fully functional (with C++) on Windows…

Cheers, Bertrand.

Hello,

Did you ever find a way to fix this? I’m working on a similar technology and encountered the same problem. Short of switching to COFF (which has its own issues), I couldn’t work out what to do about this.

Regards,

Joshua

Hi Joshua,

Not yet, I’m afraid we’ll have to wait until cling integrates the next version of llvm & clang…

Cheers, Bertrand.

Thanks for the quick reply!
Do you know that it’ll be fixed in the newer version, or just hope?
I ask because I’m on the trunk (as of a few weeks ago) and am having the same issue.

All I can say is that the latest version of clang is now compiling code that it was not able to compile with the version currently used by cling…

Cheers, Bertrand.

FYI, I posted on the mailing list about this and it’s now been fixed!
github.com/llvm-mirror/llvm/com … 9e9400f3ef