CASTOR files not readable

Hello everyone,

I get some trouble about root, xrootd, and Castor, I don’t know exactly.
I hope we will find a solution to my problem… :frowning:

I tried to access a file on CASTOR directly though root, and there is something that I don’t understand.

  1. I directly loaded my hist.root though xrootd using this path root://; And it seems to fail since the size is 0…
  2. On the other hand, I used rfdir command and I found the file.

I already staged the file, get+qry to be sure of being in the same pool and the file staged…
lxplus074:dy-analysis meyerma$ stager_get -S compassuser -M /castor/
lxplus074:dy-analysis meyerma$ stager_qry -S compassuser -M /castor/
/castor/ 1525760344@castorns STAGED


this could well be not related to ROOT but to Castor. For instance, I just tried to “rfdir” the file you signalled and got a time out. I suggest to file a CERN SNOW ticket about the issue.

In order to “unblock” your work, I’d like to signal some other widely adopted storage solutions available at CERN:

  1. EOS: … =KB0001998
  2. AFS itself. You can have a public directory there too. Perhaps it’s enough if you don’t have many very large files.

Related to 1), you can also decide to synchronise your personal space on your local device with CERNBox (