Can't save .gif files with clued0's latest root version

Please report this to the root help forum at root.cern.ch/,
they should be able to help.

– Paul Russo

Jeroen Hegeman wrote:

Mmmm, this indeed seems to be something for the real experts. The ROOT
version seems to be okay, I’ve got a local install (though compiled
with gcc4.0) which saves canvases as gif without complaints.

On clued0 I get the same result as Amnon, if I try to use the debug
version of this ROOT version, it segfaults immediately on starting…
It seems to run fine in batch mode though. Also the v4_02_00a_eh -q
"GCC_3_4_3:debug" version works fine.

Jeroen
(left clueless)

On Jun 23, 2005, at 16:03, Amnon Harel wrote:

Dear Expert Admins,

When ever I try to save a canvas in the .gif format with the latest
root version it crashes. Other formats work. My first guess is that
it’s a clued0 setup problem, since it seems too big and basic to be a
bug in the release.

To repro (tried it on gamgee and pippin):
setup D0RunII p17.05.00
setup root v4_04_02b_eh -q "GCC_3_4_3:opt"
root
TCanvas c1
c1->SaveAs(“bla.gif”)

Cheers,
Amnon

Hmm, that version seems to have been built incorrectly. I’ve rebuilt
it, try:

setup root v4_04_02b_v2_eh -q GCC_3_4_3:opt

It works for me.