Can't Launch RooFit, but why?

Hi everyone!

I wanted to use RooFit and the User’s Guide says to run the ./configure of ROOT with the option --enable-roofit and then .

I followed the instructions, but ROOT does not recognize RooRealVar, for example: i notice it does not change colour; to better explain myself, after i set the option --enable-tmva and it worked perfectly, TMVA changed colour when i typed it in the ROOT terminal…
On another computer, in which i am sure RooFit works, RooRealVar changed colour after being typed

The version of ROOT i have is 5.34.34

Thanks for reading and help (and sorry for my english…)!


You can check if ROOT has been built with roofit by typing

root-config --has-roofit

If the answer is no then your build is without it. Either you misspelled --enable-roofit (or -Droofit=On when using CMAKE) or using in reality a different root executable.
In case you should also check the output of configure (or CMAKE).

Best Regards


Hi Lorenzo!

I followed your instructions and it worked!
Thank you very much :slight_smile: