Cant get ACLiC to work on Windows XP


I’m using root 5.13/04 on Windows XP.

I seem to have a problem making ACLiC work. I tried running .x binomial.C+ in root/tutorials doing the following. Can you tell me what I am doing wrong?



  1. I launch a cmd window.
  2. I make sure to set the appropriate variables by running "C:\Program Files\Microsoft Visual Studio 8\Common7\Tools\vsvars32.bat "
  3. I make sure msvcr80.dll is in my path (C:\Program Files\Microsoft Visual Studio 8\VC\redist\x86\Microsoft.VC80.CRT), as are c:\root\bin and C:\root\lib
  4. I start root and type .x binomial.C+


I get the gollowing output

Right at the beginning I get a popup window which says

To simplify steps 1 and 2 above I ran the .bat file in the attachment to launch the cmd window ( I had to change its name to *_bat else I could not attach it)
root_bat.txt (1.69 KB)


I assume you built ROOT yourself? Could you check with the


Hi Axel,

Actually I did not build root myself but just used the libs/dll’s which the install msi puts into the c:\root* directories.

I ran DependencyWalker on the root.exe in C:\root\bin and see only a dependency on MSVCRT.DLL (none on the DEBUG version). However, there is no dependency on MSCVRT8.dll. Is this the cause of the problem as my cl.exe comes from VS8?

In DependencyWalker I see several dependencies on VS7.1 (ie MSVCR71.DLL, MSVCP71.DLL) so I tried using the vsvars32.bat file from VS71 but got he same problem as before.

Finally looking at the discussion thread in your second link I uninstalled root and installed the root from BNL (the qt version). Then I get the error

Is it necessary to build root get ACLiC to work?



[quote=“supandey”]Is it necessary to build root get ACLiC to work?[/quote]For now and with MSVC8: yes, you’ll have to build ROOT from source, because we don’t offer MSVC8 binaries yet.
Cheers, Axel.

Thanks for the information. It helped. I now focused on a VS7 solution.

Apparently this combination works for me.


  1. Root 5.14/00
  2. C:\Program Files\Microsoft Visual Studio .NET 2003\Common7\Tools\vsvars32.bat
    3), 4) as above.