Can't find vdt/vdtMath.h when building ROOT

I’m trying to parallel the TKDTree. As I building it after finished writing, the building crashed with

In file included from input_line_12:7:
/home/fsol/Documents/f2/builddir/include/ROOT/RVec.hxx:36:10: fatal error: 'vdt/vdtMath.h' file not found

#include <vdt/vdtMath.h>
Error: /home/fsol/Documents/f2/builddir/bin/rootcling: compilation failure 
math/vecops/CMakeFiles/G__ROOTVecOps.dir/build.make:68: recipe for target 
'math/vecops/G__ROOTVecOps.cxx' failed

I only edited TKDTree.h and TKDTree.cxx file (you can go to check my editing)

_ROOT Version:master
_Platform: Ubuntu 64bit 16.04 in VMware
_Compiler: cmake 3.5.1

Hi, this is a problem with target dependencies not being added by CMake. We have fixed it in master and 6.14 branches, but for now you can work around the problem by compiling VDT, then ROOT. Just run the following in the build directory:

$ cmake --build . --target VDT
$ cmake --build .
1 Like

Thank you! It solved the problem.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.