Cant compile against root lib anymore

Hi All,

I just wonder if someone can tell me more about an error like this (full make output is at end):

/usr/bin/ld: skipping incompatible /afs/ when searching for -lCore

The strange thing is: it worked fine yesterday. I am in the same shell window, same code, same make file even still the same log in from yesterday. but: peng! it does not compile anymore with this message.

And I am clueless! something must have happended with the lxplus machine (lxplus222) but I would need some hints at what to look at!


Thanks in advance

g++ -g -o PixelResidualsAndPulls -L/afs/ -lCore -lCint -lHist -lGraf -lGraf3d -lGpad -lTree -lRint -lPostscript -lMatrix -lPhysics -pthread -lm -ldl -rdynamic -L/afs/ -lCore -lCint -lHist -lGraf -lGraf3d -lGpad -lTree -lRint -lPostscript -lMatrix -lPhysics -lGui -pthread -lm -ldl -rdynamic PixelResidualsAndPulls.o
/usr/bin/ld: skipping incompatible /afs/ when searching for -lCore
/usr/bin/ld: skipping incompatible /afs/ when searching for -lCore
/usr/bin/ld: cannot find -lCore
collect2: ld returned 1 exit status
make: *** [Pixel] Error 1

Looks like the usual problem on lxplus where you run on a 64 bits node and link with a 32 bits library. Check your settings.