Can't build root 6 on macOS sierra 10.12.1

Hi all,

after updating to 10.12.1 I was trying to build root6 and had quite some problems with it. The main problem seems to be, that it can’t build freetype (and it doesn’t accept my already installed freetype version).

After several tries, here is what I tried in the end:

git clone root mkdir root-built10 cd root-built10 cmake -DLZMA_INCLUDE_DIR=/usr/local/include -DLZMA_LIBRARY=/usr/local/lib/liblzma.dylib -DPCRE_INCLUDE_DIR=/usr/local/Cellar/pcre/8.39/include -DPCRE_LIBRARY=/usr/local/lib/libpcre.dylib -Dlibcxx=ON -Dmacos_native=ON -Dcocoa=ON ../root > cmake.log
I also had problems with lzma and pcre before and installed them using brew. See also the attached log

The building crashed at about 61%, when trying to install freetype. I think this is the problematic part of the log, but I also attached the full log for freetype.

Maybe anyone has an idea how to fix this?


Btw: I already tried several other methods. I was able to build root-6.06.08 using xcode (cmake -G Xcode …), but then I couldn’t create any TBrowser, pdf, or similar. (As already mentioned by llista here: Compilation problem with: OS Sierra, Xcode 8, ROOT 6.06.08)
freetype_config.txt (8.35 KB)
cmake.txt (11 KB)

After upgrading the MacOS you need to ‘re-install’ the Xcode command line tools. After the upgrade the directory /usr/include is gone :frowning: , which should have essential C header files like stdio.h. Just execute:

xcode-select --install

Well that was a surprisingly (and embarrassingly) easy solution. I was convinced I already did reinstall Xcode. Turns out, I didn’t and this fixed my problem.