Cannot compile v5-3X-00 on Fedora 18

Hello all,

I’ve tried to compile ROOT, v5-30-00, v5-32-00 and v5-34-00, on Fedora 18 and it failed. It seems to me to be something related to “fchmod” which is already defined in /usr/include/sys/stat.h.

Please, see error message bellow:

/home/gbarros/Software/root/53400/src/build/rmkdepend/main.c:64:12: error: conflicting types for ‘fchmod’
In file included from /home/gbarros/Software/root/53400/src/build/rmkdepend/def.h:42:0,
from /home/gbarros/Software/root/53400/src/build/rmkdepend/main.c:30:
/usr/include/sys/stat.h:298:12: note: previous declaration of ‘fchmod’ was here
bin/rmkdepend -R -fcint/cint/src/g__cfunc.d -Y -w 1000 – -pipe -m64 -Wall -W -fPIC -Iinclude -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__64BIT -DG__HAVE_CONFIG -DG__NOMAKEINFO -DG__CINTBODY -I/home/gbarros/Software/root/53400/src/cint/cint/inc -I/home/gbarros/Software/root/53400/src/cint/cint/src -I/home/gbarros/Software/root/53400/src/cint/cint/src/dict -pthread -I. – /home/gbarros/Software/root/53400/src/cint/cint/src/g__cfunc.c
make: bin/rmkdepend: Command not found
make: *** [cint/cint/src/g__cfunc.o] Error 127

I tried the compilation in both ways, i.e. by typing “./configure” then “make” and also with cmake. The error is always the same.

Any suggestions?

Thank you in advance.


You can install ROOT from the repository

yum install root-*

Having the same problem 5.34.01, Fedora 18.

…but it seems fixed with 5.34.04! :smiley: