Cannot compile ROOT v6.22.08 with Debug symbols and all options

Please read tips for efficient and successful posting and posting code

ROOT Version: 6.22.08
Platform: Fedora 32, Fedora 33
Compiler: g++ (GCC) 10.2.1 20201125 (Red Hat 10.2.1-9),

Hi all, I’m experiencing issues compiling the ROOT 6.22.08 release with all options and Debug symbols -Dall=ON -DCMAKE_BUILD_TYPE=Debug.

The install script I am using combines installation of dependencies and actual build steps. Install script can be found here Install CERN ROOT v.6.22.08 on Fedora with Debug symbols · GitHub

Below please find the build output to console on Fedora 32:

[ 10%] Copying header /home/petrstepanov/Source/root-6.22.08/tree/tree/inc/TreeUtils.h to /home/petrstepanov/Downloads/include
[ 10%] Built target move_header_tree_tree
gmake: *** [Makefile:172: all] Error 2

And on fresh install Fedora 33:

[ 27%] Building CXX object interpreter/llvm/src/lib/Support/CMakeFiles/LLVMSupport.dir/Watchdog.cpp.o
[ 27%] Linking CXX static library ../libLLVMSupport.a
[ 27%] Built target LLVMSupport
gmake: *** [Makefile:171: all] Error 2

I have identical script that installs older version 6.22.06 and it works just fine on F32 and F33. Therefore the issue must be related to the recent ROOT 6.22.08 version.

Not sure if I have to post it here or open issue on GitHub. Looking forward to hearing from you!

In your “” script, right before “cmake -Dall=ON ...”, you are missing “cd ~/Source/root-6.22.06-build”.

Actually, in order to build it in a “clean” way, I would use something like this:

rm -rf ~/Applications/root-6.22.06; mkdir -p ~/Applications/root-6.22.06
rm -rf ~/Source/root-6.22.06-build; mkdir -p ~/Source/root-6.22.06-build
cd ~/Source/root-6.22.06-build

and then (make sure that nothing in the environment points to any other ROOT version):

# clean the PATH somehow, if needed, too
cmake -Dall=ON ...
1 Like

Hi @Wile_E_Coyote , thanks for providing recommendations with respect to the build. I have tweaked the install scripts and made sure:

  1. Install and build directories are wiped out before the build.
  2. ROOT related environment libraries are unset before the build.
  3. Build is carried out in a dedicated directory.

I have attempted to build ROOT 6.22.06 on both of my laptops and it worked well. However, ROOT 6.22.08 build does not go through. Terminal output is following:

CMake Error at /home/petrstepanov/Source/root-6.22.08-build/XROOTD-prefix/src/XROOTD-stamp/XROOTD-build-Debug.cmake:49 (message):
  Command failed: 2


  See also


I also attach output from another log file referred above /home/petrstepanov/Source/root-6.22.08-build/XROOTD-prefix/src/XROOTD-stamp/XROOTD-build-*.log. Here it is:

[I] No git repository info found. Trying to interpret VERSION_INFO
[I] Using the user supplied version: v4.12.8
[I] src/XrdVersion.hh successfully generated
/home/petrstepanov/Source/root-6.22.08-build/XROOTD-prefix/src/XROOTD/src/XrdCl/ fatal error: uuid/uuid.h: No such file or directory
   45 | #include <uuid/uuid.h>
      |          ^~~~~~~~~~~~~
compilation terminated.
gmake[5]: *** [src/XrdCl/CMakeFiles/XrdCl.dir/build.make:369: src/XrdCl/CMakeFiles/XrdCl.dir/] Error 1
gmake[5]: *** Waiting for unfinished jobs....
gmake[4]: *** [CMakeFiles/Makefile2:2150: src/XrdCl/CMakeFiles/XrdCl.dir/all] Error 2
gmake[3]: *** [Makefile:150: all] Error 2

Both laptops with Fedora 32 and 33 refer to the same error. I think the problem is that ROOT 6.22.08 requires extra dependency, namely libuuid-devel. I will reach out soon an let you know how’s it going.

I have issued a Pull Request with updated dependencies required by ROOT on Fedora linux. Some library names were mistyped and some were added: R-devel, R-Rcpp-devel, R-RInside-devel, python3-numpy, libuuid-devel.

Recent ROOT version with debug symbols and all options compiles fine now. However I am not sure if libuuid-devel is a required or optional dependency. So maintainers will need to review my PR. Thanks!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.