Can not build Garfield after upgrade ROOT

Dear Experts

I accidentally upgrade ROOT from 6.22.08 to 6.30.00, so I need to rebuild Garfield++. But when I try to build I got such error when I run cmake $GARFIELD_HOME:

CMake Error at /Applications/ (message):
  Could NOT find Vdt (missing: VDT_INCLUDE_DIR VDT_LIBRARY)
Call Stack (most recent call first):
  /Applications/ (_FPHSA_FAILURE_MESSAGE)
  /opt/homebrew/Cellar/root/6.30.00/share/root/cmake/modules/FindVdt.cmake:63 (find_package_handle_standard_args)
  /Applications/ (find_package)
  /opt/homebrew/Cellar/root/6.30.00/share/root/cmake/ROOTConfig.cmake:132 (find_dependency)
  CMakeLists.txt:71 (find_package)

Is this an issue or I did something wrong? I didn’t do anything instead of accidentally upgrade ROOT version…

ROOT 6.30.00
CXX: Clang 13.1.6
Fortran: GNU 13.2.0

Maybe @hschindl can take a look

No idea, sorry. Is this problem specific to building Garfield? Or do you get the same error when you build a ROOT-based application without any Garfield-dependency?

I tried to rebuild Geant4 examples, but no error came out…
Maybe you can try to build Garfield++ with ROOT 6.30.00 and if there is no error then it should be something else :cold_sweat:

OK a GitHub issue has been open cmake find_package ROOT broken with 6.30, nlohmann and vdt are builtin but not found · Issue #14163 · root-project/root · GitHub"

Note: if I “source” root before calling cmake, then the VDT error disappears.

I tried to source before calling cmake, but error still come out :frowning:

So I propose to try to install VDT on your system (if available), or downgrade ROOT until a proper solution is found

Thank you! :slight_smile: I think I will downgrade ROOT

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.