Can I disable the maximum root file size?

Root version: 4.04/02g from source
OS: Linux

If I fill a TFile with more than 1.8 GB of data, it seems to open up a new TFile with an underscore and number, where the number is the number of times there was more than 1.8 GB of output, appended to the filename. Is there any way to turn it off? I looked around, but couldn’t find anything.

It is a restriction on the data-structure maybe? I am using TTrees.

see: … ChangeFile


So the best solution would be to use TTree::SetMaxTreeSize to set the trigger-size to some number larger than any harddrive’s size in GB? You can’t disable the triggering and calls to ChangeFile()? Why have a maximum file size in the first place?

There are many reasons why we set a max tree size. Just a few below
-It is more efficient to process 100 files of 2 Gbytes than a 200 Gbytes file when doing parallel processing (eg with PROOF)
-It is safer in case your job crashes (or hit you volume quota).
-tables in memory are much smaller