Building time? (v.6.06.02 in Linux)

How long should the build (or make) time be?

My setup is a Fedora 23-64bit system, with GNU make 4.0 .

The installation options are:

./configure -all make

Mine has taken more than 2 hours(!) and still running…! I believe it is too long!
If I can understand well from the System Montitor it uses one core all the time (%CPU is maximum at 25%)


edit: just cancelled. more than 2.30 hours, id say its extremelly long… maybe I try it again…

Try make -j4
It’ll make it approx 4 times faster

And, I haven’t tried -all so I don’t know what it is
but usually the packages configured by just ./configure are enough

oops! just before I fell onto this
which describes what u said.
so i 'll give it a try with -j 3 or 4 and just ‘./configure’


Do not use “./configure” with ROOT 6 (it’s known that it’s broken) -> use “cmake”.


the CMake sytem of ROOT also provides an option to speedup re-compilations of ROOT with ccache ( Once ccache is available is available on your system, just add “-Dccache=ON” to the cmake options. For example:

cmake -Dccache=ON /path/to/my/root/sources 


here some numbers:

/configure linuxx8664gcc --enable-roofit --enable-minuit2 
    --with-dcap-incdir=$LIBDCAP/include --with-dcap-libdir=$LIBDCAP/lib 
Enabled support for asimage, astiff, builtin_afterimage, builtin_ftgl, builtin_glew, 
builtin_llvm, dcache, explicitlink, fftw3, gviz, genvector, mathmore, memstat, minuit2, 
mysql, opengl, pgsql, pythia6, python, roofit, search_usrlocal, shadowpw, shared, sqlite, 
ssl, tmva, vdt, x11, xft, xml, xrootd


time make -j3
real    10m59.322s
user    29m59.722s   <-- scales with Nof(cpus) roughly
sys     1m53.223s


Ubuntu 14.04.4, gcc 4.8.4
CPUs: Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz

Btw: Pepe, what means: “Configure is broken for root6” ?


Hi Otto,

I think Pepe is trying to suggest that the main configuration and buils system of ROOT is CMake. As such new features are added to it even if the “classic makefile” insfrastructure is kept alive and bug free.


well I just compiled today morning on another computer, an iMac(MAC OSX 10.11, i5@2.7GHz, standard 1tB disk) , using only:

make -j 4

and it made it quite fast don’t remember exactly but lets say around 30min…
it seems that ROOT works ok (even with simple ./configure option)

I 'll give it a try with cmake on the first mentioned laptop-fedora…

Finally, I tried this today on the aforementioned Lenovo Thinkpad with Fedora23.

$ ./configure linuxx8664gcc  --enable-fftw3 --enable-minuit2
make -j3

It took 1hour 05 min. I continued working on my laptop will make was running…

Not that bad I 'd say.


I have to mention that it actually failed. as written here

root6 or older does not work(cannot be built with gcc 5.2 which is stock in Fedora23-they are known to have all the latest software)

so, donot use gcc-5.2 it FAILS building ROOT.


You could try to install (or build by yourself) a previous version of gcc (e.g. 4.9) and then build ROOT6.

See also: