Building root on Ubuntu 13.10

I am using ubuntu version 13.10.
i tried fixed location installation for root following instructions from page … oot-source

Please tell me the architecture i should use for ubuntu 13.10
in command
./configure [] --prefix=/usr/local

what is shown when you type simply

ROOT should be able to determine automatically the best architecture.

I run

[code] ./configure --prefix=/usr/local

at the end i got
To build ROOT type
make install

after that i type make i got error at the end as:

/home/ramanpreet/Downloads/root/build/rmkdepend/main.c:64:12: error: conflicting types for ‘fchmod’
extern int fchmod(int, int);
In file included from /home/ramanpreet/Downloads/root/build/rmkdepend/def.h:42:0,
from /home/ramanpreet/Downloads/root/build/rmkdepend/main.c:30:
/usr/include/x86_64-linux-gnu/sys/stat.h:298:12: note: previous declaration of ‘fchmod’ was here
extern int fchmod (int __fd, __mode_t __mode) __THROW;
Running /home/ramanpreet/Downloads/root/build/unix/
Making include/compiledata.h
Running /home/ramanpreet/Downloads/root/cint/ROOT/
Making cint/cint/inc/configcint.h
bin/rmkdepend -R -fcint/cint/src/g__cfunc.d -Y -w 1000 – -pipe -m64 -Wall -W -fPIC -Iinclude -DR__HAVE_CONFIG -DG__REGEXP -DG__UNIX -DG__SHAREDLIB -DG__OSFDLL -DG__ROOT -DG__REDIRECTIO -DG__STD_EXCEPTION -DG__64BIT -DG__HAVE_CONFIG -DG__NOMAKEINFO -DG__CINTBODY -I/home/ramanpreet/Downloads/root/cint/cint/inc -I/home/ramanpreet/Downloads/root/cint/cint/src -I/home/ramanpreet/Downloads/root/cint/cint/src/dict -pthread -I. – /home/ramanpreet/Downloads/root/cint/cint/src/g__cfunc.c
make: bin/rmkdepend: Command not found
make: *** [cint/cint/src/g__cfunc.o] Error 127

Which ROOT version are you trying to install?
It seems that your problem is common on old ROOT versions. This compilation problem may be fixed in the latest version (5.34/15).

i tried installing ROOT version 5.34.14

after typing make i got error at the end as:

g++ -shared -Wl,-soname, -m64 -O2 -Wl,–no-undefined -Wl,–as-needed -o lib/ graf2d/x11ttf/src/TGX11TTF.o graf2d/x11ttf/src/G__X11TTF.o -L/usr/lib/x86_64-linux-gnu -lfreetype -lz -Llib -lGX11 -lGraf -lXpm -lXext -lX11 -lXft -Llib -lCore -lCint -ldl
graf2d/x11ttf/src/G__X11TTF.o: In function (anonymous namespace)::DictInit::DictInit()': G__X11TTF.cxx:(.text+0xd): undefined reference toROOT::RegisterModule()'
collect2: error: ld returned 1 exit status
make: *** [lib/] Error 1


I have seen similar problems when older parts of ROOT were present in the system. Even incomplete installations of previous version can create troubles. Could it be your case?

i have a directory named ROOT in my computer.

i tried to open it or tried to move it to trash but could not.

i got error as:
You do not have the permissions necessary to view the contents of “root”.

Open a terminal, go to the directory where your directory ROOT is, log on you as superuser (root) and type

You should be able to remove this directory.

my root is not in a directory,
it is in device called computer,
in terminal when i type

ramanpreet@raman-pc:~$ cd Computer
i got

bash: cd: Computer: No such file or directory
i typed code:
whereis root
i got
root: /usr/bin/root /usr/bin/root.exe /etc/root /usr/bin/X11/root /usr/bin/X11/root.exe /usr/include/root /usr/share/root /usr/share/man/man1/root.1.gz

i typed code:
cd /usr/bin/
and i used code:
rm -fr root

i got error as:
ramanpreet@raman-pc:/usr/bin$ rm -fr root
rm: cannot remove ‘root’: Permission denied

i also tried using code:
rm -R root

i got:
ramanpreet@raman-pc:/usr/bin$ rm -R root
rm: remove write-protected regular file ‘root’?

Oh oh, do not to stuff like “rm -r” in /usr/bin directory…
So, the result of the “whereis” command says that ROOT is installed (it does not mean it works well).
So let us start to the beginning.

  1. Download the root archive from this link.
  2. Open a terminal and go to the directory where the archive has been downloaded
  3. Untar the archive with this command
  1. Go to the new directory doing
  1. Type
  1. If you have no error message, log on you as root typing

and then your root password
7. Then type

make uninstall lake distclean
to clean up you previous root installation
8. Unlog you typing “exit” (afet that you be logged as a “normal” user with your usual name)
9. Type

to compile ROOT
10. If the compilation went well, log on you as root with “su” command
11. Type

when i typed

[code] su

i got error:
su: Authentication failure

After typing “su”, you should have an empty line in your terminal.
So just after “su”, you have to type your root password.