Building Root 6.22.06 from source Ubuntu 20.04

I am trying to create ROOT from the source in Order to use Pyroot.
While running cmake – build . --target install i get the following error:

[ 90%] Building CXX object tmva/tmva/CMakeFiles/TMVA.dir/src/NeuralNet.cxx.o
In file included from /home/henry/root/root_src/tree/tree/inc/TTree.h:36,
from /home/henry/root/root_src/tmva/tmva/inc/TMVA/DataSet.h:47,
from /home/henry/root/root_src/tmva/tmva/inc/TMVA/MethodBase.h:54,
from /home/henry/root/root_src/tmva/tmva/inc/TMVA/NeuralNet.icc:15,
from /home/henry/root/root_src/tmva/tmva/inc/TMVA/NeuralNet.h:1312,
from /home/henry/root/root_src/tmva/tmva/src/NeuralNet.cxx:3:
/home/henry/root/root_src/core/meta/inc/TClass.h:326:88: error: ‘TDictionary::EMemberSelection’ has not been declared
326 | Members(std::atomic<TListOfDataMembers*> &data, TDictionary::EMemberSelection selection, bool load);
| ^~~~~~~~~~~~~~~~

make[2]: *** [tmva/tmva/CMakeFiles/TMVA.dir/build.make:1083: tmva/tmva/CMakeFiles/TMVA.dir/src/NeuralNet.cxx.o] Fehler 1
make[1]: *** [CMakeFiles/Makefile2:26220: tmva/tmva/CMakeFiles/TMVA.dir/all] Fehler 2
make: *** [Makefile:171: all] Fehler 2

Has anyone an Idea how i can fix this?
And would it be possible to use a prebuild version of ROOT in order to use Pyroot?

Thank you for your answers and your help.

_ROOT Version: 6.22.06
Platform: Ubuntu
Compiler: Not Provided

I don’t know about the error (maybe @moneta or @Axel can tell what’s wrong) but you absolutely don’t have to build from source, see for a few installation options. I would recommend to install ROOT as a conda package.


1 Like

Thank you very much for your fast reply.
I’ll try the conda installation tomorrow and will reply again.
I wish you a nice evening!

I’ve installed root using the conda package as you’ve recommended. My only problem now is that it seems like I’ve not the needed knowledge to use the PyROOT version of ROOT in PyCharm.
I tried adding /…/lib/ROOT to the project Structur :

ERROR in cling::CIFactory::createCI(): cannot extract standard library include paths!

Still looking for a way to fix this, would appreciate any kind of help.


Hoping I’m not the only one who has a hard time with all this I’ll just post the solution.
Maybe someone is happy about it.

Have a nice Day and stay healthy,