Build root under VS2003 and Cygwin

Hi all,

I tried to build root 5.04 for Windows XP using Cygwin and Visual Studio 2003.
The next command were done
./configure win32gdk
make install
The root was build in the I:/Cygwin/home/root/5.04 and result was installed in the d:/root/work. When I tried to start root from any directory the next error was shown: the application failled to initialize properly (0xC0000022). If I started root from the directory I:/Cygwin/home/root/5.04/bin it works. What is wrong? The key variables have the next values

$ echo $PATH

$ echo $LIB

$ echo $INCLUDE

$ echo $ROOTSYS

Thanks in advance,

there’s no need to run make install. Simply start root from I:/Cygwin/home/root/5.04/bin (and don’t forget to update $ROOTSYS accordingly).

Hi Axel,

It is not suitable to me. I have some VS projects that are used ROOT address as d:/root/work for the including of libraries and header files.
I can exclude make install command. But how I can move the code in a new place.
Is it good to move root source in the d:/root/work directory and translate it there? Also when root is started I do not see a windows with root title, which is created for a short time when I start CERN binary version. Is it correct?

Best Regards,

Hi Axel

ROOT source was moved in the d:/root/work directory and translated there. After that ROOT works and it starts with a small windows showing its title for a short time as the CERN binary version.
Is it possible to move the binary version in a new place and how it could be done. This question remains an open to me.

Best regards,


I wrote that ROOT works without using of make install command. It is correct. But when I translated own code with this version the next message was obtained -
Error in TCint::LoadLibraryMap: library map entry, no system rootmap file found. ROOT not properly installed.
In spite of this message my code begin to work. But what does this message mean and how to overcome it?

Thanks in advance,

run “make map”.

Many thanks Axel.
Now the code starts without error message.