Build of 5.34.18 hangs

I have an octal core x86_64 machine, kernel version 3.13.0-29-generic, running ubuntu 14.04.

After unpacking I configure using

Then I start the build by doing

It comes to

[size=85][quote]g++ -shared -Wl,-soname, -m64 -O2 -Wl,–no-undefined -Wl,–as-needed -o lib/ graf3d/gviz3d/src/TStructNode.o graf3d/gviz3d/src/TStructNodeEditor.o graf3d/gviz3d/src/TStructNodeProperty.o graf3d/gviz3d/src/TStructViewer.o graf3d/gviz3d/src/TStructViewerGUI.o graf3d/gviz3d/src/G__Gviz3d.o -Llib -lGui -lGed -lGpad -lGraf3d -lGraf -lGeom -lRGL -Llib -lCore -lCint -ldl
==> lib/ done
g++ -shared -Wl,-soname, -m64 -O2 -Wl,–no-undefined -Wl,–as-needed -o lib/ math/genetic/src/GeneticMinimizer.o math/genetic/src/G__Genetic.o -Llib -lRIO -lHist -lMatrix -lTree -lGraf -lGpad -lTreePlayer -lMLP -lMinuit -lMathCore -lXMLIO -lTMVA -Llib -lCore -lCint -ldl
==> lib/ done
==> lib/ done
==> lib/ done


…and hangs.

I end up control-C-ing it. If I run again using make -j1, it states that the build was successfull:

[size=85][quote] ============================================================
=== Run ‘source bin/thisroot.[c]sh’ before starting ROOT ===


But if I try again with make -j8 it hangs again. Not sure what’s going on. When I run root, it overall
seems to run fine, however there are some strange elements of behavior that I haven’t seen before.

I was going to submit a post about root build hanging, and came up against my own post from a year ago.

I am having a very similar problem, this time around with 5.34/30. First, here is the system info

Has anyone else seen this?


No, this is a unique failure… It must be something in your environment.

I’d suggest to do the following once the build hangs:

ps -feH |less

look for make, and you’ll see its sub processes enuerated below. The culprit, the one causing the build to hang, will be the sub process without children. If this doesn’t make sense / doesn’t help please post the output of that command, everything including and below “make”.

Cheers, Axel.

Axel, thanks for the reply.

I eventually got everything working by doing simply make -j1. I do remember checking with top,
and make was taking up 100% of the cpu.

Next time I run against this I’ll look at the sub processes as you said.

p.s. to be clear, the problem that I had a year ago was on a different laptop, and wasn’t ubuntu 14.04. The
only thing common between the two events is my self. :slight_smile:


Weird. I only ever saw make itself eating 100% on cygwin (with weird error messages included) - likely because some of their patches broke it. Other than that it always behaved nicely. So please do post the ps tree if this happens again.

Cheers, Axel.