ATLFast with ROOT 5.20/00


I am using ATLFast in ROOT 5.20/00, and I am having some issues retrieving the ATLFast object from the output file (it would be useful for the event display for example).

To be more precise, when I run umain.C with a prodmode <100 (generation of the events by the macro), everything seems to work fine and I can retrieve the ATLFast object (for instance I can run the macro display.C on the file atlfast.root created, or I can see the contents of the atlfast object in a TBrowser).
But, I would like to generate myself the events with another generator. I put the output of the generator into a ROOT file pythia1.root, containing a TTree named “T”, containing a TClonesArray of TMCParticles named “particles”. I can run the macro umain.C normally with a prodmode of 101 for instance. The problem is that I get a segmentation violation as soon as I try to open the ATLFast object of the file atlfast.root (for instance I get this segmentation violation if I run the macro display.C or if I click on “atlfast” in a TBrowser where atlfast.root is opened). On the other hand, I can do a MakeClass on the TTree “T” of atlfast.root, and I can loop this way on the content of the TTree, all this works.

Maybe I am doing something wrong when I create the file pythia1.root… But I don’t see what, and anyway the reconstruction works normally.

Thanks by advance for your help.


Could you try with either version 5.22 or 5.23/02 and let me know?
Could you post otherwise your file.root?


So far it seems to work with version 5.23/02 of ROOT. I should have tried it earlier…

Thank you for your help!