Accessing file. server responded with an error

I’m in root on lxplus trying to open a data file and I’m getting a lot of errors back. This is my first time trying this, I’ve just set it up so I might have done that wrong. But I tried opening the file with:

root [2] TFile::Open(“root://”)

And it gives me:

160603 05:53:24 19223 Xrd: CheckErrorStatus: Server [] declared: (error code: 3010)
160603 05:53:24 19223 Xrd: DoAuthentication:
XrdSec: No authentication protocols are available.
160603 05:53:24 19223 Xrd: GoToAnotherServer: Error handshaking to []
160603 05:53:24 19223 Xrd: Open: Error in handling a redirection.
160603 05:53:24 19223 Xrd: CheckErrorStatus: Error while being redirected for request Open
160603 05:53:25 19721 Xrd: XrdClientMessage::ReadRaw: Failed to read header (8 bytes).
160603 05:53:29 19223 Xrd: CheckErrorStatus: Server [] declared: No servers are available to read the file.(error code: 3011)
160603 05:53:29 19223 Xrd: Open: Error opening the file /store/user/velicanu/Merged/Pythia8_Z30mumuJet_pthat30Norm_TuneCUETP8M1_5020GeV_cff_ppFOREST_PrivMC_v10/0.root on host
Error in TXNetFile::CreateXClient: open attempt failed on root:// … v10/0.root
(class TFile*)0x0

So that’s a lot of errors. I think I’ve used the correct xrootd redirect per the CMS Offline workbook, I’m in New Zealand so I use the global one. I’ve loaded my grid certificate onto lxplus, set up my runtime environment in lxplus with cmsenv inside my CMSSW_5_3_32/src directory. I’ve set up ROOT with the 2 lines it tells me in the workbook:

root[0] gSystem->Load(“”)
root[1] AutoLibraryLoader::enable()

I don’t know what’s happening so any help would be very much appreciated.


Hi Zac,

I understand you are using a full CMSSW environment, is this correct?
This does not seem an issue of ROOT, the one shipped with CMSSW_5_3_32, but rather something which has to do with your grid certificate.
This is all very experiment specific: have you tried posting on CMS Hypernews?