6.02-patches build problems on OS X 10.10.3

{I tried to post this on the roottalk mailing list so apologies if this is showing up twice.}

I am having trouble building rootv6.02 against macosx 10.10.3 . I tried following the instructions here but am still having problems:

groups.cern.ch/group/roottalk/L … 3BF0CDA2A4

I’m starting from the OS X CommandLineTools:

DN0a22178d:root-v6-02 tompkins$ xcode-select -p
DN0a22178d:root-v6-02 tompkins$ xcode-select -v
xcode-select version 2339.

I tried

git clone root.cern.ch/git/root.git root-v6-02

cd root-v6-02
git checkout -b v6-02-00-patches

./configure macosx --enable-python


but during compilation first got this warning:

ld: warning: ignoring file /Users/tompkins/installations/root-v6-02/interpreter/llvm/inst/lib/libclangFrontend.a, file was built for archive which is not the architecture being linked (i386): /Users/tompkins/installations/root-v6-02/interpreter/llvm/inst/lib/libclangFrontend.a

…(and many similar)…

then got many undefined symbols errors:

Undefined symbols for architecture i386:
"_LLVMInitializeX86AsmParser", referenced from:
(anonymous namespace)::createCIImpl(std::__1::unique_ptr<llvm::MemoryBuffer, std::__1::default_deletellvm::MemoryBuffer >, int, char const* const*, char const*, bool) in CIFactory.o

ld: symbol(s) not found for architecture i386
clang: error: linker command failed with exit code 1 (use -v to see invocation)

make: *** [core/utils/src/rootcling_tmp] Error 1

There were some errors during my ./configure. The config.log file is here: cernbox.cern.ch/public.php?serv … 207145b21b

And I don’t understand why its trying to use a 32bit build when

DN0a22178d:root-v6-02 tompkins$ uname -a
Darwin Laurens-MacBook 14.3.0 Darwin Kernel Version 14.3.0: Mon Mar 23 11:59:05 PDT 2015; root:xnu-2782.20.48~5/RELEASE_X86_64 x86_64

DN0a22178d:root-v6-02 tompkins$ clang++ --version
Apple LLVM version 6.1.0 (clang-602.0.49) (based on LLVM 3.6.0svn)
Target: x86_64-apple-darwin14.3.0

Thread model: posix

thanks in advance for the help,

Try: cd WhereYourRootSOurceCodeIs unset ROOTSYS make maintainer-clean ./configure --enable-soversion --all make

Thanks! I had initially installed root from the binary but deleted it when it didn’t match my python installation. I completely forgot that $ROOTSYS was set! Once I unset it the installation worked fine.