Trying to use root2lhco tool


I just installed ROOT on my Ubuntu 18.04 laptop, so I am new to it. I am working with MadGraph and trying to convert some .root results of different events to .lhco file for further MadAnalysis analysis. :wink: I have installed Delphes and also ExRootAnalysis. I added path to Delphes to .bashrc, so that I can call the tool root2lhco from anywhere, but when I try to run it, I get a very long error, which you can find in the appendix. As far as I was searching the internet I found some replies about adding the ROOT_INCLUDE_PATH variable, but now I am not sure, where to point it to. I already tried pointing it to Delphes, ROOT and ExRootAnalysis.

Can anybody please help me? Thank you in advance,

error.txt (28.3 KB)

Can you try to locate the ".pcm"s that cling looking for? We discussed such problems in this thread:

1 Like

Thank you for your answer. So I added the rdict.pcm to LD_LIBRARY_PATH and there is less error messages and it produces the output. However, in root file, there is 10 000 events, while in the output, there is only 2500? I also still get some errors (included in appendix) - from the requested link/topic, I found that .h files should be included to ROOT_INCLUDE_PATH, so I added the .h files from the error messages to the path, but the error is still there.

Thank you again!

error2.txt (721 Bytes)


Don’t add the headers to ROOT_INCLUDE_PATH but only the directory necessary to find ExRootAnalysis/ExRootConfReader.h etc. I.e. if you have /my/home/delphes/exroot/ExRootAnalysis/ExRootConfReader.h, ROOT_INCLUDE_PATH should be /my/home/delphes/exroot.

Regarding the number of entries: as we don’t know what root2lhco does (that’s not a ROOT thing) we won’t be able to be of much help with it. Maybe ask the Delphes people?

Cheers, Axel.

1 Like

Thank you very much for your reply, that solved every problem. :+1: :slight_smile:
It still produces only 2499 events, but I will search for help elsewhere.