Tips for Efficient and Successful Posting

This forum is intended to help with problems, allow individuals to collaborate on the ROOT project, to answer questions, and generally communicate and debate, especially in relation to using or programming with ROOT. Before you ask a question, or post in these categories, please observe the following guidelines:

  1. Specify which ROOT version, which platform and compiler you are using

  2. Don’t use all caps.

  3. Use descriptive Title. Do not put URGENT!, or NEED HELP NOW, etc. in your title; it will not make people look at it any faster.

  4. Add a self-contained reproducer (+data if needed) or at least describe the “steps to reproduce” to help us to understand/solve your problem

  5. When posting code, do not post your entire program if you only need help with one function. Post as little as possible. People are much more likely to read small amounts of code and help you, than they are to read a hundred lines of code.

  6. Use code tags (```) whenever you are posting code more than a line or two in length. More information on code tags can be found on the sticky topic on the top of the ROOT category.

  7. Don’t ask people to do all your work for you. It is especially discouraged to request completed Tests, Quizzes, and Assignments, or graded work.

Thank you,
Bertrand.

Drawing a histogram from a root file in pyroot
How to perfectly fit exp. data with 5 gaussians
ERROR in cling::CIFactory::createCI(): cannot extract standard library include paths! after Ubuntu upgrade
Warning: invalid memory pointer passed to a callee in c++ code
libTBB build failure (and solution)
Setting up ROOT environment
Want to create a 2D histogram from two different branches in TTree
Makefile:143: *** Error: main91 requires ROOT. Stop
Drawing multiple TGraph from two txt file
Fitting two kind of function
How can I perform multiple Gaussian fit on a "rebinned histogram"?
I got a problem doing histogram tutorials
Opening root files over network using TBrowser using root 6.22
Access particle charge using PDG-ID scikit-hep particle package in RDataFrame
Running fast-jet and fast-jet contrib in RDataFrame
Fixed Color scale for multiple 2-d histograms
Keep getting a segmentation violation when trying a TH2d to file
Creating function libraries
Function convolution with parameters
I had a problem when i integrate histogram
TH2::Interpolate() fails for some values
TTree and Branch
What to do with a TH1* from file no longer needed
I can’t fit with TF2
X-maximum and x-minimum values TH1F
AddressOf and SetBranchAddress with ROOT 6.22 and pyRoot
GetEntries output when multiple branches exist
EVE Viewer Export
Bugs in TFit? Errors when trying to fit a histogram
Problem with dividing TCanvas for multiple RDataFrame Histograms in pyROOT
Set parameters or fix parameters in fitting function
Seg Fault using TCutG IntegralHist() method
Normalize histogram and triangle histogram
How can i access $ROOTSYS directory?
Read Valgrind log
Fit Parameters from an array of Histogram on text file
Histogram empty
Garfield++ / Root Errors - fatal error: TCanvas.h: No such file or directory
How to use ROOT?
Bug in invocation of namespace in Root
Plotting Histogram
Drell-Yan simulation
Root build from source
Drawing ROOT Histogram from File is empty
Orient TPaveText
How to supply matrix data to a TMatrixDSparse object?
TH1 Draw Bug: E3 producing same results as E4, E2 also incorrect
ROOT reference guide broken?
Path to pcm files
Show only text of TPaveText
Is it the root problem?
ROOT 6.24/06 can not work on macOS Monterey
Draw a plot of 2 variables
Why Canvas don't create window
Adding contour lines into my contour plot
Removing 'GRAPH' legend
TLimit at 90% CL
How can i set x axis and y axis in scatter plot?
Skipping empty entries in a TBranch
Plot variable distribution with histogram under unknown range of this variable
Getting the x-coordinate of the global maximum on TGraph
Texts' positions and sizes in variable-sized pads
Fail to build root from source with errors
Sub-folders in a tree
Binding energy plot
Gaussian fitting of multiple peaks using TSpectrum
Asimmetric tgraph error
This branch does not exist?
Warning: unknown platform, assuming -mfloat-abi=soft
Basic code of c++
Changin the name of an existed histogram
RDataFrame from root command line - exceptions causing root exit
Normalized a histogram with line but without error bar
2D TEfficiency Calculation
Fitting one function to multiple ranges simultaneously
Ratio plot of two histograms
Easy way to update ROOT?
RDataFrame Python string formatting
An unwanted horizontal line is drawn at y=0
Branch selection
Plot multiple hystogram from two TTree of two root files
Is there a generic way to know components of the TTreeFormula?
Increase the color intensity in my contour plot
Vertical line in plot
Running from non-installed location problem
Fitting of mutiple peaks in the case of unknown number of peaks
Installing root for using pyroot in Anaconda package
How to make a simple error on histogram?
ROOT 6.18 not searching under /usr/local/include for header
Segfault when defining new column with gInterpreter
Show () command in root
Add branch to one tree to another one, strange peak
Histogram and data integral with entries different
Can we write a .root file with a .c code
Computing cross-correlation of two time-series, stores as TGraphs
Position of scientific term of TAxis
Problem building ROOT from source on mac os 10.15 (Catalina)
Making tree branches with vector<vector<int> >
Is there a binary version of ROOT for macOS Catalina 10.5.2 I could download and use out of the box?
Error Building "makefile" : cant find some library
Error Propagation in TF1 class
GDML import tessellated/triangular geometry
Maximum and minimum colour using the "COL" option in TH1::Draw
How to install root on windows 10?
Installing root 6.10.04 on ubantu 18.04
Error in <TFile::WriteTObject>: Directory gates.root is not writable
TCanvas putting histogram row wise
Root 6.24.00 Compilation error with Mac OS Big Sur 11.2.2
Plots using jsROOT not being displayed / remain blank
Crash when plotting four histograms
Reweight a histogram with a weight of histogram form
TEveCompount segfault
How to disable the invoking of C++
Problem with Time Display
ROOT (master) compilation fails for libROOTNTuple.so in ubuntu 20.04
How to display the entries and details of a particular histogram when multiple histograms are plotted on a single plot
Arrays of Double32_t not recognized as arrays?
TTree basket size inflating and exhausting memory
How to save the multiple histogram in one pdf
Bug with compiled code using TClass / dictionaries in Root 6.24
How to set label size globally in rootlogon.C?
Fit Panel -- problems fitting with a user function
Running root in each directory in windows
Change text direction of TLatex
I wanna delete root and install again
What is nbinsx , xbins?
ROOT doesn't draw TCanvas
THttpServer automatic page reload
Histograms of dose profile and surface dose distribution
Generating streamers for pythia8302 with cmake
SetParameters in fitting
Install ROOT5.34.34
Writing an object to tree
Float16_t really encoded on 16 bits?
Some 'how-to' questions on Histograms
Cint Limitation on 3D TGraph arrays?
Set precision for the "TEXT" option of TH1::Draw
Compute uncertainty of integral of a component of a TF1
How to add two TBox class variables?
Question on vector<vector<int>> using RDataFrame
Module 'std.codecvt' is incompatible with feature 'header_existence'
TF1::GetParLimits after FixParameter and ReleaseParameter
Changing Axis Titles on THStack
Problem with root on macos: error: module 'Darwin' uses additional module map
TGLViewer SavePicture not exporting .eps and .pdf properly
TMath::IsInside() always returns false
How to evaluate the fitting result is good?
Newbie: Graphing error
Ubuntu install error about xrootd
Plotting individual points on a TGraph?
TH1F LabelsOption(">","X"); NOT working sometimes
Accessing TNonSplitBrowsable
Error when installing ROOT6.18.04
TGenPhaseSpace in PyROOT
Error when instaling to about 57%
Error in <TTreeFormula::Compile>: Invalid Syntax "&&"
Relative frequency hystogram
Cumulative distribution function
Copy Tree with weights (bootstrap)
TGPictureButton Not connected
Missing packages
How to access histogram of TF1 drawn with DrawCopy()
Problem with main() and no output root file
How do I import root classes when using cmake?
Numbers as histogram names in CINT
Garfield / Root Errors
ROOT lags when creating large multi-dimensional vector of TH1 pointers
Using ROOT on lxplus
Same error keeps appearing even when macro is changed
Program using GetX() working in root 5.34 but not root 6.18
MakeSelector and TTreeReader usage problems
Dynamical allocation of TString : malloc (C-like) crashes, new (C++-like) : fine : why?
Error compiling root 6.24 on Mac OS Big Sur
TNetXNGFile::Open fails with double slash (//) in path
Marking an region with different background color in TGraph
How to draw new graph with new point?
TFile read objects: deletion of TFile pointer is really slow
Better resolution in plots
Library not loaded: @rpath/libGui.so
Reconstruction of top quark
Import a Date and Time from txt file into a Tree
Error messages displayed on opening root
Fitting at end of bin
Problem opening Displays using root on Macbook Air
TMultiGraph axis ranges not being used
APPLE updated MacOS to 12.0 SDK
Understanding installation of Root
Gaus generator for histograms
Error on opening root
Wait function in root
Reading and writing ttrees
String on TGraph axis
Filling maps and vectors in a single tree
Can't figure out the error
TTree Fill Error
Migrate from PROOF to RDataFrame + Spark
Root, OpenGL, X2Go
Environment variable not working
LEGO plot: scientific axis label
How to set PYTHONPATH when I obtain "Import ROOT error . No module found"
TGeoManager units
Histogram operations
Undeclared identifier error
Normalising a histogram directly
Selecting events from multiple time ranges
I am getting error when I am doing remainder opearation
Using brew root with pythia8
Enforce c++14 in CLING
Problem with remainder operator in root
Some doubts on Contour Plots
How to update an existing Tree?
TH2Poly::Interpolate or meshing surface
TAxis label math expression problem
Read problem on ULong64_t data type
SQLite tutorials
Find closest value in a column of a TNtuple?
Mathmore affects result of ROOT::Fit, Roofit results unaffected
Ntuple or TTree
Root installation Ubuntu 18.04
Install ROOT 6.24.00 on MacBook Pro mid 2014
Merging ROOT files with hadd
Filling histogram with errors
Adding histograms to already made .root file
No type named 'DataLoader' in namespace 'TMVA'
ROOT and Catalina
Installing PyRoot, which version of Python was Root built against?
How do I change the title of my plot?
Set range for a 2D Histogram
How to slim the branch array in RDataFrame
Geant4 simulation to ROOT ntuples
Draw command in histogram
Reversing X-Axis
Fit of an array
Creating an array of TVectorD objects?
Parameter space values from Minuit
Reading TRefArray with RDataFrame in PyROOT
TGraphErrors with root 6.18
Axis label position
Undefined symbol when excuting
Automatic pointer for a TBranch
Creating and filling root tree in separate functions
Problem accessing root variables in array form
Creating a better contour plot
Draw X-Axis with specific values
Static Compilation of a ROOT Class Dictionary
TH3, TF3 and GL crashes
Calculate the sigma between results of the same mesurement
Compare histograms with Chi2Test, which option?
What does TPaveText->SetX1NDC do and how to solve my related problem?
Turning Warnings into Errors
*** Break *** segmentation violation after certain point
Export geometry to root macro
TGraph2D - rebinning axis
Root don't want to work with GATE geant4 compilation
Como instalar Root para ubuntu 14.04.3?
Draw selection with float value
PYROOT: Fill histogram with numpy array
Increment by variable names in SetBranchAddress
How can i fit the histogram?
Unable to display the histogram entries and standard deviation
How to use the objects in the library that is loaded with gSystem with g++ compiler
Error when simulating optical processes using a Geant4 based software
Z-axis labelling in TGraph2D
Create a function based on a simulation
How do I list files in a directory?
What's with my code?
How can I loop over a number of directories
Joining TProfile end to end
Installing root with Conda
Draw Files on Same Canvas
Parametric range definition
Find the bin of 2D histogram for each event
Installing ROOT with R on lxplus
TH2::SetShowProjectionX() draw style
Build of v6.26/02 failed again in compiling CPPConstructor.cxx
Landau definition in ROOT
No matching member function for call to 'GetObject' on TFile object
Can Root geometry package be used in Geant4?
Segmentation fault executing SetPoint in script
Legend: fit curve entry and transparency
Set preprocessor #define values before compilation
Set event status bar visible by default
Start up tutorial for using CERN data for simulation
Wrapping exec object in pyroot
Error: no matching constructor for initialization
What is the reason behind the static TClonesArray in the JetEvent.h example
Non-linear Regression (for Time Difference of Arrival)
Errors and contours of fit parameters
Saving in png with allowed OpenGL.CanvasPreferGL is black figure
Extra space in axis titles
ImportError: Failed to import libcppyy3_7. Please check that ROOT has been built for Python 3.7
IncrementalExecutor::executeFunction: symbol '_Z4sqrtf' unresolved
How can I normalize an Energy Spectrum by solid angle?
Drawing shapes on a TGraph?
Snapshot of Rdataframe creates two identical trees with different cycle number
Byte count too large error while copying histogram
Crash in XGetGCValues
gStyle->SetOptFit(1111) having no effect on fixed variables
Question: How to set defaut options on all root sessions
Conda ROOT and Jupyter notebook
How to save information in log file
How to use ROOT::Math::DistSampler?
How to use TEventList correctly
How to uninstall root cleanly for the snap version
Student's T-Test in ROOT
Docker Image for v5.34/24
Initializing Muon Vectors: How to
$HOME/.rootrc not working
Now that Python2.7 is not maintained anymore, is pre-compiled ROOT (going to be) shipped with Python3 bindings?
TLegend single label with multiple line attributes
Saving a fit at a root file
Weird behavior when using option "same" when plotting branches
Seg. fault for loading the library with dev3
How to change -std=c++11 to -std=c++11 in root under lxplus.cern.ch
Bug in TCanvas::SaveAs C-macro
TTrees not hadding properly
How to Extract Variable from Branch in ROOT
Displaying data of several histograms simultaneously
Show fitted function works differently (?) than before
Error in TDataFrame
Can't open graphs from Terminal
Remake ROOT with Python3
Optimal Unbinned Maximum Likelihood Fit- Python
Finding number of Muons
How to Add a Branch as a Vector to be Used in the Invariant Mass Vector
Making Branches with class objects
Reading Histogram from root file
Specify minimum/maximum colour for colour palette
Separate axis when dividing a canvas
Is it possible to normalize or divide one axis of THnSparse by another TH1D histogram when we do THnSparse::Projection in 2D?
Plotting multiple palettes on the same TCanvas
Weird ROOT bug?
Issues with void function inside macro
How do I read data from a .dat file in root?
WebSocket client using civetweb
XML parsing for I/O
Canvas PDF export bad quality
Macro for multiple plots in one canvas
Dear experts, Can you suggest me the PDF use for fit of the #DeltaE distribution?
ROOT v5 on CentOS8.x?
Getting List of histogram name from Flat Ntuple or simply a root file
Unable extract correct data from Hits tree of ROOT file obtained from GATE simulation
No module named ROOT while executing script in windows
How to use GetEntryNumberWithBestIndex()?
ROOT 5 on Mac OS 10.15?
CMAKE python version mismatch?
Write names on the x label instead of the numbers
Call C++ function with vector argument from PyROOT
Write .txt file by TFile
Multigraph problems
Fill a histogram
Fill a histogram
Issues Setting Up geant4_vmc for Monte Carlo Simulations
How to expand RDataframe functionalities in a custom compiled code
Histogram axes limits discrepancy warning/error
Polymorphism with TClass::New() after dynamic loading of derived class library during runtime
*** Break *** segmentation violation while closing .root file
Using the new Minimizer class on ROOT 5
How to initialize RVec
Change axis label density inTH1
Can't use set function for TVector2
How can i get rid of CMake Error at home/usr/
Accesing members/methods descriptions defined in the header comments
Dumping plot in py
Understanding THStack Output
Axis range problem in TGraph
Printing in terminal crashes root
Can not plot graph?
Linker Error if compiling a simple graph in VS
How to run .py scripts in linux
Scatter plot matrix from TTree
TArrow size and position
Std::bitset streamer: endianness issue?
AnaConda Root coud not install
Free(): invalid pointer:
Multiple histograms from one TTree
Only integer number on x label
How to exit root in terminal?
Addition of histograms from different files with the same name
Check for empty RDataFrame
Install root for ubuntu 20
Easily aggregrate 2 Rdataframes with same n(entries) in a sorted way
Importing and visualizing gdml with tessellated solids
Warning in <FlushXOROps>: No CrosshairWindow found to draw into
Segmentation violation on Big Sur 11.2.3
Candle plot from mean stderr max min
Adding a Branch of class to TTree
ROOT Data Frame Tutorial; Combinations
Logos in plots with vector output as a style
Getting error like 'generate the dictionary for this collection (map<string,bool>)'
Combining two built-in functions for fitting
"Error in <TNetXNGFile::Open>: [FATAL] Invalid address" message while accessing files
RBrowser cannot be launched
ACLiC compiling scripts and give name
Copy root file without cut events PyRoot
Remove directory
Brazil-flag plot using TGraphAsymmError
Assessing the similarity of 2-Dimensional histograms
Facing error while installing Tauola
The fault figure occurs when plotting Double Y axis figure with logarithmic coordinates
PYTHIA 8 for ROOT
Uniform distribution
The type of TTree parameter
Install root 6.22 on ubuntu 20.04
Accessing a dynamically allocated ROOT object after reference lost
Updating a ROOT object in file creates multiple copies
Ways to work around the redefinition of compiled functions in one single Notebook session?
Delete dynamically allocated TH1*'s
ROOT on Windows 11 WSL2 / WSLg
Root is not working and stop
Generic polycone unsupported by GDML parser
Root is not working and stop
Regarding programming
Merging Datasets using RDataFrame
Compiling issue on macosx
ROOT compilation fails at target Imt (by making function call that is not there in libtbb)
Mathematical procedure of TH1::Fit
Unknown type name 'TGraphMultiErrors'
How does the Add function work?
How to select events in a 2D plot to make an ellipse
How to convert this ROOT.PyIntBuffer class to an integer or array object that can be handled by python? (PyROOT and Marley related)
Control C in gdb ignored
Clear screen in CLING
Label title axis and SetOptStat
ADC to energy scale conversion, re scale x axis TH1F
Problem with RDataFrame::Snapshot in python
Normalization of TF1 (function) for log likelihood unbinned fit method
How to draw 2D scattered plot with its projections in same canvas like the attached figure?
TChain in Root 6.12.06 - Break Segmentation
OriginPro and root
Draw both histogram line and marker
Slow graphical ROOT interface with MacBook Pro Catalina
Problems while exiting root .q with canvas
Root latest release upgrade
Root update error
Support for multidimensional arrays with TTreeReaderArray
TGFileDialog check if cancel pressed
Change marker style for some point or other solutions
How to compile a c++ file on windows 10 using root and Makefile?
SetFillColorAlpha doesn't work
Autocompletion with VS Code
Can't change axis label for TH1 frame
Difference between Root dict and LCG reflex dict
Unzip a single basket to see if it is corrupted
Conda root crash
How to generate vector<"heder file">. please help me out
How run this macro?
Calculation of fit errors
What to the numbers after an object name in a ROOT file indicate?
Installing python bindings on an already existing root setup
Radware matrix to ROOT
Pyroot & jupyter
Error shows on running ROOT after installing in windows 10
Error installing root on Linux device
In uproot4, how to replace "allitems" of uproot3
How to overlay one histogram on another?
How to import "times signal" "dot or bigdot or bullet" when plotting pictures using TH1D class?
Installing root in Windows 10
No module found, import ROOT error
Retrieve xlow, ylow, xup, yup for TPad
TH1::Print to show bin errors
ROOT build fails on Monterey
ROOT6 cling dictionary generation bug or feature?
Issue with 2D histogram plotting
Chaining RDataFrame::Define does not work in some cases
Distribution shape change for every try
Can't compile code
Color of Histogram
The difference between htemp got by TTree::Draw() and TH1F object
Convert a .dat file to a root file
Is it possibile to install new ROOT version in Monterey 12.3.1?
Help with reading a TTree
TTimeStamp and TBranchElement status
TEve Beginner Question
Previous definition is here
Is there a limit on the size of a char[] "string" branch?
Using a macro multiple times
Question of C++
How can i draw scatter plot?
Problem running root after update to Mac Catalina
Create a new branch with input tree branches
Cubic polynomial fit 4 points has uncertainties
Reading histograms from TFile gets slower and slower
AXIS EQUAL Command
Add include path and library in PROOF
Root.exe does not exist!
Automatic exit of root in windows
How to do a significance scan (signal-background) from a histogram in a root file
What is the correct use of "TBrowser *"?
Integral Error in Signal
TRatioPlot in a Canvas.Divide() environment
Sort a tree using "time" variable
Problem after installing root in windows 10?
Isodraw 7.1 issues
How to write a shell script to run a root macro created by MakeClass()?
How do I produce multiple canvas from a macro?
Read from TTree
I wanna draw 2 fitting graph. But it shows only one graph
Writing TTree w/custom container class - variable length arrays
6.21 install directory changed
Segmentation violating from GetEntry
Split large root tree file to small root tree files
Error title TH2F
Switching code from pyroot to C++
Start Legend neatly from top
Data Corruption when Cutting a TTree
My fiiting function for convolution crashes
Dictionary usage with Python 3
Square root of histogram
Histo changes bin and entries when switching to log scale
Other file types for ROOT file
Draw histogram of a class member in TBrowser
Problem compiling with root
Rescale x axis of histogram
Building Root 22
Windows 10 WSL VS Code : No such file or directory error
Can't fit a histogram loaded from file
XRD GSI auth fails
RDataFrame with weight
ROOT stopped working, suddenly
Image does not show in pop up canvas
Unable to run a C++ ROOTbook
SetDecimals() in TGaxis not working
Thank you for fixing PyROOT compatibility!
Drawing canvas distorts legend parameters
ROOT::Fit vs RooFit
Compilation failed: V6.19/01(github master) with VS2019
Using data files in root
Multiple TGraph2D - Issue when using SetPoint
Error while loading shared libraries - libCore.so
Root 6.22 cmsenv python
Error: TFile.h: No such file or directory
OSX Mojave + ROOT v6-20-06 + Python 3
Convert TString to string_view
ROOT master segfaults inside ubuntu18 docker container
RDF filter the content of branches
Setting Histo1D in pyROOT
Remove stats box from fitted TGraph
How to save my modified TH1D into my existing *.root files with TBrowser?
Logistic function fit
Fill histogram by file
Compiling from source: First interactive command hangs
Error when running any Event Display tutorial/program on OSX
Setting a gate on a cube
PCM file not found
JSRootCore.js Error in Jupyter
Facing problems while installing root 6.10/04
Invalid pointer to histograms created via TTree::Draw
What is the best way to plot an oscilloscope trace in ROOT?
How to install root without TMVA packages
Sometimes the axis range can not be defined by users?
Read integer from txt file of 1D containg dat
Any way to define a var name CONTROL in root script?
TPython::Exec() crashes on root imports
Select on char when using TTree Draw() function
Integral from data file
std::vector<ROOT::RDF::RResultPtr<TH1D>> th1v; slow writing many histograms
How to suppress _all_ error/warning output
Creating root file
RDataFrame catching undeclared identifier error
Is GroupBy operation natively implemented in RDataFrame?
Root on /cvmfs/
ROOT Compilation failed with Mac OS Catalina
Problem with drawing lines using TMultiGraph with gPad -> SetLogy()
GUI interfaces of ROOT with high resolution display (HiDPI)
ROOT library (so)versions
Bug in cmath pow? (typecasting, symbol unresolved)
RootV7 RNtuple examples
Entry range in TNtupleD
Do ratio between two TEfficiencies (or TGraphAsymmErrors)
Clusters of the processed RNTuple data set
How can i make a fitting better?
TSpline5 interpolation
Resetting the bin content and recalling the bin content error
R__unzip_header: error
Problem with fopen filepath nesting
CMake: ROOT component PyROOT is not found
How do I copy a leaf from many ROOT files into one?
LaTeX in PDF vs PNG
Add 2D plot in a tree branch
Compiling ROOT 6.18.04 with GCC 9.2.0 on lxplus
Advanced TFormula and TF1 usage
How to install Pyroofit?
Error: cannot initialize a variable of type 'TH2D *' with an rvalue of type 'TH1 *'
What file type to save TFitResultPtr
Changing graph titles through a loop
Control length of line in legend
Problem with RDataFrame::Fill in python
Converting file to ascii
Include Root header to Geant4 error: Undefined symbols for architecture x86_64: "TVersionCheck::TVersionCheck(int)
Exponential plot
How to write data from a branch
Installation problems root
tree->Print() does not produce any output
Root catalina bug report
Copy Branches to a Tree
Error in <TInterpreter::AutoParse>: Error parsing payload code for class
Setting ROOT for a dummie
Print Branch with array data
Problems after moving to Catalina
Compilation fails under Catalina MAC OS X
Plot with extrapolation and interpolation
Hadd: corrupted size vs prev_size problem
Delete or uninstall ROOT
Root and virtual machines
Problem with this code for plotting interference pattern
How to copy a branch into another root file
RDataFrame::Snapshot and TDirectory
A bug on TSQLServer at Mac os platfrom
Color part of histogram
TList::Add(TObject *) and TList::AddLast(TObject *)
Changing the size of TCanvas on the go (Run Time)
TF1 vs TFormula parsing of "expo(0)"
Branch renaming failure (?)
Enum for TAttLine:SetLineStyle(Style_t)
OUtput file error
https://youtu.be/s9PTrWOnDy8
Error creating output file
Making a pointer to histogram in subfolder to make fits
Problem in installing root while doing cmake
Histogram styles with DrawNormalized
Anchor TGaxis in a fixed position and zoom
Process data with saved cuts as cut.C
Increase smoothness of drawn curves
TEve Buttons not working for next events
Installing 6.20.04 fails on Ubuntu 20.04
Interval of intersection doesn't work
Ratio plot for multiple graphs
Saving Histograms from tree based Root file into a new root file
Pythia-root interface
Hadd failure on files produced by same executable
TLatex: subscript far below with integral
Sample splitting using RDataFrame not working for the trees which contains vector branches
Tree print and show in python
Issues with RDataFrame if name and leaflist of a TBranch are different
Copying variables from Delphes ROOT files to new ROOT files
Macro Runs Fine in Root 5, Seg Fault in Root 6
Undeclared Identifier when running macros
Order of Print() statement output in distributed execution
Histogram containing dots in name
TH2Poly::Draw("text") omitting negative numbers
Filling objects in pyROOT
Using ACLiC to compile a macaro
H2root conversion failed with error
ROOT TFIle.Open in threaded Python3 program
Incorrect Histogram Plot
Fitting a Linear Function
Binning w/o entering?
*Break* Segmentation Violation Error
Exponent label in a graph
TGrapherror, can't get error bar
Setting y axis limit in a function plot
Convert from .C macro to png
Error when trying to execute main()
Why is an "error: redefinition of [variable]" occurring every time I run code more than once?
Fisher distribution diverging where it shouldn't
New column RooDataSet
Multithreaded analysis doesn't seem to recognize null initialization of TH1D objects
Event display Editor
Combining any user defined function with a predefined function for fitting
TPySelector.h is missing?
Error in <DrawPolyLineAux> when drawing TCutG in editor
Get data from tree's branch to txt
Problem in Draw()ing a histogram w/ variable bin size in logarithmic scale
TTree Alias as the start of symbol
Root Files Portable?
Read histogram from root file and do it a canvas
Multiple TGraph in a single TCanvas
Infinity Chi Squared Value
Error when running python 2.7 script on lxplus7
User defined class
Libtinfo.so.5 on ROOT CERN
Ratio plot problem
Compile ROOT projects with Visual Studio
Problem with error bars and logarithmic axis in variable bin histos
Passing symbol from interpreter to library, workaround?
Get maximum of a function
Rerunning a macro error and recommendation for a bug-free ROOT version
Using cout in root
Compiling issue
Spectrum does not find and show right peaks
How to fit with non-function
Using fftw3.h in root
Reset to 0 top "N" bits in a TH1x
Vtd header files are not accessible
How do I read from a TNtuple?
TLegend ugly in subfigures
Accessing the value of pi in ROOT
Setting a constant number of decimal points on plot axis
How do I actually install ROOT?
Cern root install error for ubuntu
Default Location of accessing macros
Use of THnSparse
Using examples given in documentations as a newbie
Shutdown of root window on undeclared identifier
Declaring libraries in root
Reset ROOTDEBUG
Segmentation violation when compiling stand alone
Question about time stamp
Saving ROOT.Numba.Declare callables in Python?
Can't find $ROOTSYS directory
Plot variances in each bin
Reading order of Documents for learning root
Fill the histogram with mean=1 and sigma=2
Shade area for TH1
Gaussian elimination on a TMatrix
Error in <TFile::WriteBuffer>: error writing all requested bytes to file
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3, from ROOT 6.20.00
Changing default directory for accessing macros
Installing ROOT from the source
Get TFitResult for each slice from TH2::FitSlicesY()
How to plot Graph from text file
Add TH2 with your settings and options for Add()
How to draw graph after dividing two set of points?
Legend font and graph size
How to select events randomly?
Comma separated CSV file
How to use TSpectrum to locate peaks
Create and read a ROOT file
How to get the pointer of the default canvas in a TBrowser object
Error in TCutg :: Proof Selector
Integrate ROOT into my project with CMake
Birth of nonexistent events in THStack
Compare two TLorentzVectors for equality with operator==
Issues building with v6.20.04 with GCC 10.1.1
How to install root on mac os x 10.15?
Creating data files for practice
Building ROOT on windows 10
Failure loading library libMathMore.so for ROOT::Math::GSLIntegrator
Trouble compiling with Python 2.7 on Fedora 31
Precision of axis labels
Not show labels
3.6f in an histogram example
TAxis::SetLabelSize documentation
Problems while exiting root .q with canvas (2)
Installing Root on Mac Problems not Configuring
Histogram Functors for RDataFrame
Equalise font sizes of histograms drawn on different pads
Equalise axis title offset
Automating TBranch setting and filling with std::variant
Extracting a fit form a class function
Problem callding RDataFrame::Define with ColumnNames_t with python
Compile error using RDataFrame: fatal error: 'vdt/vdtMath.h' file not found
Head scratching issues with RDataFrame
Persisting alias of a ttree
3TH2F in a 3D graph
Histogram clips at the top
TChain: Adding files by reading filenames in a text file
Draw vertical error bars of TGraphErrors
Tab completion in pyROOT in an IDE environment
Code Crashing with RVecs
SVector addition operator?
Print parameter of function (TF1)
Deregister TTreeReadeValue in TTreeReader
Giving title to divided canvas
Many documentation and faq links are broken on root.cern.ch
Writing already defined function
Problems configuring ROOT (Latest) for centos7 from cvmfs
Problem with histograms after saving to file
Attempt to add histograms with different axis limits
How to change Branch Names in ROOT
RDataFrame conditional weight assignment
Rootmv with large ntuple from DataFrame Snapshot fails to move
Embed ROOT in wxwidget application using Code::Blocks on Windows 10
port root6 with Error in <HandleInterpreterException>
Bug report DrawClone!
PyROOT: Finding local minima/maxima in a TGraph
How to fillcolor at selected Bins of TH1D class object?
TVirtualPaveStats.h:33:43: warning: extra ';'
ROOT not launching
Applications that inherit from TRint and SIGINT
Draw Histogram from .txt file. I tried with the already available answers, but didn't work for me
Write data on a txt file
Convertin TString to string and vice versa
Update/Reset TDatabasePDG
Where is my thisroot.sh?
ROOT macros compilation
Linking ROOT libs with cmake in Windows
Making a Cut when Projecting a TNtuple?
Two datasets in one canvas
Sum of 2 different cuts
Reverse Axis for TGraph and Fit
RDataFrame Snapshot columnList
Reading alias of branches in a loop?
Using Cern Root library with Emscripten
How to Count Events within an Odd-Shaped Region?
Fatal error when starting up ROOT for the first time
Ploting two histograms on same axis
A problem about opening a file
Hadd 100 GB TTree
Variable reference from PyROOT
Good day . I am new to roofit and i am fiiting a crystal ball fit to my signal. Please help me
TChain not finding trees in input file
Root with xcode
PyRoot TCanvas is not persistent
Plotting histogram from the discrete user defined function
Analyse chain root 6.18.00
Making weighted histograms with continuous lines
Tcut when I import a TH1F from a file
Not Getting my second points in TGraph
Getting String Value From Branch
List of TH1F is not returned from the function
R__LOAD_LIBRARY help
How to fill two different histogram by two different colour?
Draw macros for histogram
ROOT RDataFrame does not has AsNumpy()
gSystem->Load("mySharedLibrary.so") can not load debug info
Two histogram in one plain
How to extract values on the X-axis?
Problem in 2D graph
I draw a histogram from .txt file. The resultant histogram consist several peaks, how can i gaussian fit the histogram automatically detecting the peaks. I tried the tutorials>spectrum>peaks.C but did not succeed
Significance bin by bin
Drawing histograms on pads in canvas - only one plot shows
Plot histogram with logarithmic scale
Key of TTree appears mutliple times in TFile
TGaxis label incorrect with TF1
Double Maxwellian Fit
Running a C++ Script in ROOT
TTreeReader does not find branch, TTree::Draw finds it
Look for a specific peak in a histogram
RDataFrame use of undeclared identifier
Installing root cmake
Root installing incorrectly?
Convertying pyroot TFile in memory to c++ TFile
Scale the Xaxis
Gaussian fitting of mutiple peaks in the case of unknown number of peaks in histogram generated from .tex file (for example: test.tex). What are the change required in following code (this code is for 5 peaks)?
Fitting two peaks
Add entry to legend
Issue in compiling my code
Integration in ROOT
Integration in ROOT
Online learning in TMVA's MLP method
TH1->FillRandom(...) doesn't work with linear function
Cannot run program more than once during a root session
Print out dir structure inside a root file in a tree-form
Problems while exiting root .q with canvas (3)
Warning while rebinning TProfile histograms
How to modify a TLeaf value and reliably write it to disk
RDataFrame: upload external variables to the Define
How to extract data from root file?
TTree GetEntry memory problem
Plotting two histograms from two different files/directories in one canvas
TH2::Draw("TEXT") : set text size
How can i make a new leaf
Fitting two peaks alongs with the background
TTree GetEntry memory problem
Plot graph but an excess graph appear
How to get started with pyroot?
Issue Recognising Type Specifiers
No string_view on lxplus
The constant of decay function?
FFT on Histogram
Error "ResizePad"
Compile ROOT with Visual Studio 2019 - list of dependencies
Least squares regression to solve a rectangular system?
RooRealSumPdf inside a RooAddPdf and Generation of toys
.Draw() - appears the empty window, why?
Malloc failed error
The errors occured when using root as external library to write c++ code?
RDataFrame runtime_error
Multiple histograms / TPad - TLegend issue
Std::string linkage problem
TProof crash sometimes occuring when using compiled Tselector
Root Latex symbols not showing correctly in pdf
Get Random Points following a given TF1 distribution
Unnaturally small chi-square; no fit convergence with non-zero errors
SetFillColorAlpha not printed on eps or ps
Build fails for ROOT 6.24.00 on MAC Big Sur with M1 Chip
Ascii file to ttree
SetBranchStatus for a vector of string
Add Friend with RDataFrame
RDataframe with branch contain NaN
ROOT Can't Compile a Macro but a Makefile Can
Error running Macro
Failed when using Doxygen to transform Root source code to .chm file
Get bin number corresponding to value
Fitting a TProfile with a TF1 of type ax^b
Can somebody help me figure out what the error is? I am using emacs as Text editor. I am using root version v6.22.06
Build root like exactly like the setup in lxplus
Using GSLMultiRootFinder
Make a clone of a TChain in a TTree and filling it, in case the TChain is very big : crash
Reviving: Access RDataFrame column in function without passing argument
Difference between fit panel and programmatically fit
Signal Yield and integral of signal func tion in full region are not same
How to prevent new histograms from being written to an opened ROOT file?
Fit Get / Set Parameters
Using basic_string_view = ::std::experimental::basic_string_view
Odd RDataFrame behavior?
*** Break *** segmentation violation , *** Break *** bus error
Reading a vector of type vector<float,ROOT::Detail::VecOps::RAdoptAllocator<float> >
Check a JSON in RDF
How to uninstall Root completely, fresh install of Root 5.34.26 on Windows 10
Include ROOT 6.22 in Visual Studio 2019
Delete TGraph object with underscore in its name?
Root file cant open with TBrowser without any error message
ROOT crash after system reinstallation
Problem with DRAW Option "CONT4Z"
Given a point and a TGeometry, return the Node or volume that contains the point?
Font size for histogram
Plotting TCanvas using if, for and while
Fitting histograms convolution
Error to include root header files in C++
Cut a TTree to a new TTree
mcEventWeight cut
ROOT Compilation failed with Mac OS Big Sur version 11.2.2 on Mac arm64
Is there a way to grab the title of a TH1F histogram and print it to screen?
ROOT installation Windows problems
Hadd no dictionary for class is available
Log calculations in Root 5 vs Root 6
Problems building root 6.18/04 with builtin davix
Tutorial histogram/ fillRandom.C example The graph isn't drawn
TBrowser seems slow for large folder hierarchies
Error: Building module 'Net' implicitly
Long time to close ROOT file with O(500k) histograms
Problems building ROOT on CentOS8 (cppyy issue)
GSL MultiRootFinder "not making any progress"
ModuleCmd_Load.c(208):ERROR:105: Unable to locate a modulefile for 'AliPhysics/'
Missing definition of class TVector3
Delete multiple branches from atootfile at once
Problems after ROOT installation/update
How to fit two Gaussians on two seperate peaks in a spectrum?
C++ representation of histogram plotting
How to obtain offline file like .chm?
Cannot compile ROOT v6.22.08 with Debug symbols and all options
Store Histograms in Map as Vectors and Store as ROOT-File
Train, test, validation splitting of a root file
Plotting projections on different canvases
Add enum parsing in TTreeFormula
ROOT to hepmc file conversion
Clone tree in a file and add other branches - Entries duplicate!
One out of four TCanvas missing
How can i solve this problems? im a beginner of root plz help me...!
Unable to draw interactive plots using jsroot magic command in jupyter
Error while loading shared libraries: libCore.so.6.20 in HTcondor
TProfile Error of RMS for each bin
Why can't I access this histogram from the branch?
Export data ( .root -> .txt)
Missing libPyROOT.so
Root 6 interraction
CrosshairWindow in macOS Big Sur
RooSumPdf and RecursiveFraction with a scale factor on one of sub-components
TRatioPlot: Legend with some entries filled, but one as a "p"
Using python cutting function in drawing histogram in PyROOT
Bad design regarding the storage of statistics
Passing arguments to a root macro which is being run from a script which is passed to Condor
Machine learning with tensorflow
How can I open a root file in a Mac application
TRatioPlot (a few questions)
Looping over th2 to get the error in the histogram
Elegant ways to get a TH2D from a vector?
How can i fitting two kind of function
Building root on windows 10 again
How to improve fit/add background function and gaussians to one fit function?
TH1 GetRMS and GetRMSError
Gausian Fit in a histogram
ROOT on MacOS Catalina
Problem compiling root WSL 1 Ubuntu 22.04
Problem filling large array using TTreeReader
Plotting a 2d function
Rebinning all the histograms in root file to new root file
Process stuck when using XROOTD + Streaming from the grid + RDataFrame
Profile Plot Cutting out events in leaf arrays
Slot DoDraw() does not exist compiled guide
ROOT fails recovering a file
GUI problems (XMing)?
Do spaces matter in TBranch leaflist
Passing parameters
Installing Root6.22 from Source on Windows10
Correlation between truth and reco events
Mutexes when running inside Geant4 threads
Strange problem with schema evolution, streamer info and class versions
Running in batch mode?
Error using GetConfidenceIntervals
Problem in using Max$() with TTree::Draw()?
ROOT v6.24.00 from source
Root I/O reading a variable length array branch using streamer
How to draw the uncertainty of the line shape of fit?
HTML help links within ROOT's GUI are outdated
How to check "Math::Mnimizer" status?
Combining two canvases into one
Problem with libRIO and import ROOT
Import ROOT, .Draw not displaying image on Jupyter Notebook
Problem calling RDataFrame::Define from PyROOT with plain function
How to count no. of entries per bin in a histogram?
When i integrate the graph, the values seems to be a little
Error using Projection. Trying to dereference null pointer
Optimizing Reading Arrays from TChain
How to construct an histogram in logarithm schale from one already filled
Different random numbers, Normal Distribution
Dear Colleagues! What is philosophy for generating dicrtionaries for integrating class into root? Thanks!
Dear Colleagues! What is philosophy for generating dicrtionaries for integrating class into root? Thanks!
What is the minimal installation of ROOT on MacOS pour execution only?
Error in <TRint::HandleTermInput()>: std::out_of_range caught: vector
How to convert a text file(which has six rows) to root file
Trigger several times event loops with RDataFrame
Reading events from a TFile that is being written
Sum for each RVec column, returning an RVec
Read data from a .root file
PtEtaPhi for dimuon
6.22.04 build error on macOS
Problem with Root and Geant4
Save a TGraph in a root file
CMake macros/functions
How to send a signal to ROOT from an external Thread?
Build error on MacOS, macports... with unctrl.h / ncurses.h
Write TTrees into chunks using RDataframe
Using CopyFiles.C
Calculate cross section
Time axis with a given data
Copy existing histograms into a tree
How to use "Form" command in TString class
How to minimize by minimization class
RDataFrame not able to read branches containing array whose size is of type Short_t
Root and Gate on HPC CentOS8
Get histograms from two different files and plot on same canvas
How to call Form in python
PyRoot: filling dictionary with histograms
Errors in an empty histogram
Problem reading file to fill a TH3F
Cutting histogram using TLine
Negative value get from Gaus!
Area under curve problem
Wrong Gaussian Fit (data from File)
Problem calculating the mean values
How to add my defined function to TBrowser?
Converting root file to csv using root2csv
Unable to Retain the Style of the projection Histogram on using HBAR
Compilation error related to TUnfoldDensity::GetFoldedOutput()
Installing root on windows 10,64bit for visual studio 2019
`GLIBCXX_3.4.22' not found
Null passed to a callee that requires a non-null argument
Failed to build ROOT 6.22/xx on Arch Linux ARM
Can't built ROOT Version 6.22/06
Using gentoo closing the terminal
Different quadratic fit(Data from file)
Unable To Access Elements Using Take Action
Method "AddPoint" for TGraph doesn't work
TLegend entry for TMultigraph
Read a histogram
RDataFrame Define columns with same name
C++ requires a type specifier for all declarations
Saving pandas dataframe as TTree with RDataframe
Draw 2 objects in different windows?
RDataFrame Filter for arrays
CMSSW/Python won't write the ROOT output file
How can I get Y value in X point in TF1?
SegFault calling GetN() method of a TGraph object
TClonesArray caused mysterious crash in TTree I/O
Need help building ROOT v6.23.01 on ARM MacBook
File size of a closed remote file
Hide fitting result in terminal
Pass an TGraph2D array as argument to a minimization function
Can not open TBrowser (Ubuntu 20.04LTS)
How to convert window log csv file to .root file
How to subtract two histogram?
Divide a process in more CPU
Spread Option, "s", in TProfile
Configure: error: ROOT could be initialised
HOW to put an array into a one-dimensional histogram?
Display error at WSL
How to set TPalette color in default?
Complex number imaginary
Complex number based
Macros related problem
THStack GetHistogram?
How to refer to a leaf by a branch?
Error in Adding same histograms from different root files
Corruption when iterating and copying a tree
Show units for colour bar
Errors installing ROOT on Ubuntu 20.4 ARM (M1 MacBook Pro)
Adding a new branch from a python ML model
How to plot x variable in vertical axis and y variable in horizontal axis?
Normalize to SM higgs XS and BR
Corrupted root file check
TGLVector3 using
Feldman Cousin 90%CL
Histogram declare position matters or namespace matters
RooFormulaVar error in ROOT 6.22.06
How update the group of TF1s
How to execute a python file
Divide the bin having same events
Apply weight to each events
Extremal edges of histograms drawn incorrectly
Error propagation with variable binning
Subtracting minimum of a RooCurve from another RooCurve point by point
Using SetLimits() changes the histogram
Weird problem with TH2F
Jsroot custom html projection setting
Why the error indicate TTree::TTree not defined?
Overlay two histograms drawn by two . root files on one canvas
Root Crashes on windows 10
While(!feof(file))...... not working
How to get event weight for mc sample
Error during make phase on cluster
Segmentation Deviation
Finding the Tree name in a .root file
How to use RDataFrame in pyROOT to loop events and calculate weighted efficiency?
How to declare global pointers like gSystem?
Add a branch to an existing tree in another .cc file
Roofit libraries not available to compile the macro in macOS 11.1
Add cuts for tree in pyroot
With RDataFrame and python, how to fill an array in to a tree and save the tree
Problem Macro crashes
Cannot draw when I doesn't using root prompt
Memory leak with RDataFrame in Python II
Operation on RooDataSet and RooDataHist
How to use root library in c++ projections?
Problem with class: Symbol lookup error
Ld: can't use -undefined warning or suppress with -twolevel_namespace
How can i draw graph is this code?
JIT compiling RDataFrame filters and defines within condor
Trivial questions about RDataFrame
TChain get entry acceleration
RDataFrame and CreatePoxy/TTreeReaderValue error for selection on string branch in Filter method
RooHypatia2 GSL errors
How reliable is TFile recovery?
TBrowser won't open
Is there any documentation for TTree::Query?
Making a TH2F plot taking data from a TTree and from a TH1F of a Root file
Root 6.22.06 install on M1 Mac
Access data from a Tree
FillColor bug in root 6.22
Save histogram in txt file
Which header file include the "gStyle" global pointer?
Read vector<vector<int> > branch
Fitting a plot just in a range
No output when plotting data in TGraph through for-loop
Marker size th2f
Root history with timestamp
Branches of vectors of vectors
Integration in c++ language
The position of the histogram data window
Histogramme filling
Tricky (to me) memory leak when creating a TGraphErrors using copy constructor
Numerically compute second integral (not two dimensional integral)
Help to extend Covariance Functor for RDataFrame functionality
High memory usage when performing simulation and TTree filling
Is is possible to install ratcage with root 6.24?
I/o streams problem (windows 7)
Possible REFLEX_GENERATE_DICTIONARY c++ standard mismatch
Usage of `include_directories` with `root_generate_dictionary`
Link ROOT to a library using the ROOT CXX compilation flags?
RDataFrame .Count() and .Report() re-looping over whole DataFrame?
Error in Pyroot tutorial twoscales.py
Multiple limit plot in one canvas
Wrong links in TGraphPainter documentation page
CUDA architecture for root?
Removing the area outside a circle
2 Pad multigraph with text on x-axis
Download error for TBB when building 6.08.06
ROOT 6.25/01 with clang: several warnings for 'REMOVE_THIS_NOW' [-Wunknown-attributes] during root compilation
TEfficiency Bayesian Posterior PDF
Coincidence matrix
How to keep calculation precision at equations solving using linear algebra of root?
Stacking 1D histograms into a 3D contour plot
TGraphErrors with X-axis of “char” type
Saving Canvas as C File Changes Colors (Seems Irreversible)
TGraphError - how to be plotting errors as a colored band
Getting TTree clusters as used by TTreeProcessorMT
Questions about using sumw2 while making ratioplot
How to get treename from RDataFrame
Index out of bounds on TMatrixDSym using RDataFrame in PyRoot
Reading Tree data from different events in the same loop (coincidences)
More than one tree with same treename in a root file
Error Integral is too large?
How to include fit parameters when writing histogram to file
ROOT with R through conda
Problem installing ROOT--XROOTD package download failure
Installing ROOT on Apple Silicon based mac
Workaround for TMath::Max( RVec<double> , RVec<double> )
Creating a contour plot from a .txt file and displaying it with a information bar
Memory issues with vector of pointers to TH1F
Failed instalation of last version root with cmake
Problem with installation latest root with cmake
How can i draw several plot in one canvas?
Histogram with "/" in name
RDataFrame multithread performance
Compilation error 'COMPILERVERSSTR'
Call TMultiGraph in a macro
RDataFrame and TMVA with KFolding
TTree filtering at PyROOT - RDataFrame
Superimpose histogram
TChain Seg violation
Inf/NaN propagated to the pad. Check drawn objects
Curve saved as polyline in root file
Selecting entries hitting two detectors
Using Texec to show a TH1F from a TCanvas pad on another TCanvas
Problem with drawing multigraph
Loading tree from a file
RDataFrame multi threading slower than one thread
RDataFrame vs TTree performances
Assigning the same magnetic field strength to a colorbar at a contour plot
Error in installing root numpy
Plotting the contour lines
C++ standards for various versions of ROOT
FFT Plugin not found?
TLegend problem
Upper limit on a 0 result
Read a Root file with branches
Regarding memory usage of TCahin Draw or RDataFrame Histo1D
Adding data from an external container to a DataFrame
Ever Since the Upgrade, ROOT and any of my programs based on ROOT don't work
Add enum class in namespace to Root
Error in pyroot using Fit.FitFCN
RootDataFrame Histo1D not filled in properly
Obtain TGeoManager from ROOT file
MacOs 11.5: Can't execute root through terminal
Starting a simple Proof-Lite code with Error in <TProofServLite::HandleSocketInput>
Digitize graphs from image
Make a Lorentz vector and extract mass using arrays in the root file
How to plot "stdev of Y vs X"?
Do graphs support alphanumeric labels?
Installing ROOT on Windows 10 OS
Calling C++ from Python
Standalone application with ROOT 6
Filter RDataFrame in a range of entries
Just-In-Time Compilation with Classes
Making the x and y axis the same axis ratio (1:1)
RDataFrame Histo2D filling with RVec's
Activating/deactivating branches
About the different Image format,pdf is dffetent
Understanding usage of RDataFrame Filter and Define functions on distributed data
__ROOFIT_NOBANNER=ON CMake option seems to have no effect
Libzip mess (ROOT cmake problem)
Why this TGraph is not being drawn?
RDataFrame -> AsNumpy as jagged arrays
PyROOT & C++: Fill TCanvas.cd(n) with a for loop
How to get the Cumulative Distribution of Data?
Warning in <TTree::ReadStream>: Couldn't read formatted data in "Voltaje(mV)" for branch Voltaje(mV) on line 1
Unable to access 'https://github.com/vgvassilev/clad.git/': GnuTLS recv error (-54): Error in the pull function
Error in executing a macro - Mac OS issue it seems
Build fails on MacOSX.platform/Developer/SDKs/MacOSX12.1.sdk
Pol1 Fitting problem
Reproduce a thf1 or thf2 using a data string from the TTree
Change in build procedure
How can I modify TH1D and TProfile public member function for variable binning?
Trees and objects
RDataFrame and Fill method with a custom class
Crash involving TUnixSystem
How to draw optimization of 2D between two variables?
Integer values on x-axis of multi-graph
Conda root and MacOS 12
Issue with rootcint in Root 6.24/02
Build of v6.26/00 failed in compiling CPPConstructor.cxx
Trigonometric
TMap::Copy() does not copy
Writing map<enum class, custom Root class> to tree
How to divide the each bin of 2D histogram to max bin
Nan in error fitting
About TCanvas::Print
RDataFrame - Define a new strcuture type branch with leaflist
H1D modifications are lazy in rdataframe?
What are the meaning of the parameters of TGeoMaterial(name, a ,z, rho)?
Getting CMSSW_VERSION from a root file
Text on x-axis instead of numbers
Vim keybinding for ROOT in interactive mode
Change the order of branches in a root file
How to call Mathematica ( or alternatives) function evaluation for specific pdfs
Integrate a user defined function
(pyroot) properly releasing memory/ending this script
ROOT.RDF.MakeNumpyDataFrame producing wrong histo
Trying to use Plugin feature with ROOT6 with -std=c++17
Histogram unify
Enabling Multi Threading in My Custom action
TGraph not accepting gStyle->Palette
Errors of my compiling in macOS!
Installing Root on POP-OS 22.04
Draw multiple fitted histograms in single canvas
Converting Geant4 geometry to ROOT
Pythia father or mother particles
Trouble builing root locally
Question on RDataFrame Vary functionality (bootsrapping samples and weights)
Is it possible compute quantities between entries in RDF?
Access members of a ROOT file
Smooth a Graph with Gaussian Function
Reading DAOD_PHYS into RDataFrame
RDF Define at PyROOT using C++ code not working
How to make stat box appear
Trouble with getting GetChiSquare() function running properly
Working with TString
Question about RooWorkspace Print
Using ROOT libraries in CONDOR batch system
How to make a C++ projection using Root 6.26.04 class library?
How to draw a TGraph2D for TF2
Drawing two histograms after normalising from different rootfiles
Build error: unrecognized command line option
How to ask a macro to wait until a cut is saved?
Can't compile with gcc in zsh shell
Understanding performance of EnableImplicitMT in RDataFrame
RDataFrame String Filter Question
Problem when filling tree from Pythia
Running Pythia8 under Root
Implementing rolling average of data (using a normalised gaussian function)
Code.h etc. have been moved in Python 3.11
Extra space when using ^
Set first axis number to draw
Particle direction
Multigraph - empty plot
Genreflex migration of Hep3Vector
Root interpolator embedded in a TF1
Python array in TH2 construction
MD5 sum on a ROOT file; do ROOT files have timestamps?
Angle wrap in TTree.Draw
Compiling ROOT 6.24 with external llvm but built-in clang
SQLite parallel insert
Position of vertical error bars in simple plot
Keyboard Layout
RDataFrame and Friend and python
Understand Axis Range
ROOT appears to be performing automatic rebinning of my TH2D by default against my will... extremely undesirable behavior
Saving output as .txt file
Compiling and Running ROOT on iOS
Fitting two curves on same canvas
ROOT dependencies can not install in CentOS8
TFolder::Clear()
Building root on lxplus with pythia6
Reading the branches of a class
Reading a JSON file into ROOT C++
Minuit2 Changing only 1 out of four parameters in ChiSquared minimization
TEve track projection
Random from interpolated TGraph2D
Analysis of the example 'fitConvolution.C' in Fit Tutorial
TF1 instantiation is extremely slow
gROOT ProcessLineFast
Make RDataFrame from TChain where 2 ntuples contains 90% of overlapping branches and do a proper snapshot
Counter give negative value and error
Unable to RUN TMVA . GUI NOT Opening in ROOT VERSION 6.22.02
Efficient way to produce a lot of Histo1D having an RVec<double> weight column
Passing arguments to function called by .Define in RDataFrame
Does Warning in hadd root files
TCanvas can not saveas png
File not closed after writing a tree to it with CloneTree()
Fit - first derivative **at limit**
How to make the X-axis to "log"
Error on Root Installation
Snapshot crashing in update mode and multithreading enabled on LXPLUS
Merge 2 branches in 1 new branch
What will get in the "cut=cut_s.data()"?
Set axis range on THStack
How to remove legend from my canvas (supplement: it was a stats box)
EVE - Reproducing alice_vsd - how to center the projected views?
Advanced usage of TLinearFitter?
Help on compile root on new arm MacBook
Converting a cube into root format
Rotating images using ROOT
Get entries random
Changing line styles using hbar option
Function DividePad() is not defined in current scope
ROOT install failed after Cmake build
Normalize sample to BR, Luminosity & XS
THStack histogram
Issue in calling a c++ template function with pyroot
How can I build vertical line on the graphic?
Opening remote xrootd file: TChain works, TFile does not work
Compilation failing because ROOT is searching for files in the source directory, and not in the installation directory
Confusion when declaring a TFile
Landau fit problem
Issue compiling ROOT master from source on Mac OS Mojave
Making a single RDataFrame from lots of files
Macro not found in file path
Debug root script called with arguments
How to build from source on Ubuntu20.04(arm64)
Root 6.22.06 and matplotlib and Jupyter - what to do?
Finding TObjects?
Error when filling the self-defined class in root file
Error when running gApplication in root v6.22
Computer hardware
Error installing ROOT 6.22.06 on MacOS 10.15.7
Creating and Sorting Vectors of Collections
Issue with 2D TEfficiency Statistical Uncertainty
When i fitting the histogram using fix parameter. How can i get the fitted grah's integral error?
Multi histogram plot
ROOT in pycharm
Memory leak with RDataFrame in Python
Error in writing file in a directory
Limit line painting on a graph
Fill all branches of a tree separately (because every branch has to satisfy different conditions)
General Least Squares with correlated data set
How can I change the color of the point in TH2F?
Building ROOT on Windows 10 + last release of Visual Studio 2019
RDataFrame speed vs TTree loop for histogram creation
Generate random numbers obeying poisson distribution
How to display events from .root files
Best way to save "long double" variables into a TTree
Geometry extract
How to enable PyROOT in windows 10?
Peak shifting in a histogram
How to save a root Draw to a text file
Jsroot display CAD stl files
Event decay problem using TGenPhaseSpace
Compiling issue with RDataFrame
Problem building root 6.22.06 from source
Randomly a segmentation fault for uninitialized TTree
Where to find the parameter of the function Draw() of TF2 class?
Boost to COM frame with LorentzBoost
Copying entries from a TTree
RooStats: Change of Constraint does not change Profile Likelihood Plot
RDataFrame and multiple candidates taggers
Shift yaxis "bin edge" in TH1
Normalising in TTree
Efficiencies with pyROOT
Accessing TGeoVolume (TGeoBBox) Origin Correctly
TCanvas::WaitPrimitive crashes in python when TCanvas is closed
How can I change the colour in the x direction only?
How to install root6.22 on win10 platform from source?
RdataFrame and jitted code memory consumption
Efficiently performing arithmetic with TNtuple branches
TGraph2D Number Error
Speed up adding files with TChain
Getting pad width
Why the solid line become line of dashes?
Write TTree out to file seems to corrupt it
Wrong range enabled by default when filling a histogram
ROOT installation and PyROOT on Windows 10
Issue with template type deduction for nested class in PyROOT
Getting details of a gaussian fit
Catching TH2::Rebin error in pyRoot
Kernel failed using ROOT C++ in jupyter notebook
Ovewrite TGedFrame
Issue with plotting uncertainity bands in post-fit plot
Can't Obtain Fit Result When Using Option "E"
Error for installing Root source in Ubuntu 22.04
How to solve the problem with hint “Error in <UnknownClass::Solve(TVectorD &>: vector and matrix incompatible”
Trying to update virtual machine to a new version of root
How can we plot the TH1 histogram with different bin width?
Is there still has the class THilbertMatrixTSym in root projection with version 6.24/04?
TFile::Open() fails with non-canonical filename (double slashes)
Accomodating two graphs on the same canvas
Upgrading from 6.22/09 to 6.24/02
ROOT complier issue
What is the problem in draw cut?
Error: illegal pointer to class object <histogram> 0x0 1401
Fast Fourier Transform on TH1
Load different Libraries (VTK Libraries) to the Root
C++ code keeps crashing
RDF read std::vector<std::vector<double>> from TTree
ROOT7 TTree->RNTuple example (ntpl003) with vector fields
How to plot graphs at different stations
Fitting double gausian
TRatio in graph
Performance of TAxis::SetTimeDisplay()
Editable TGedFrame
How to install root with pyroot in apple m1?
Copy histogram from a root file
TFractionFitter: MC templates shifted
Data rate when reading a file
TChain::LoadTree()
Adding a circle on a contour plot
TEfficiency using histograms from a separate root file
Plotting the data points from Tefficiency in customized bins
How to draw histo BEFORE return?
Error in installing Root 6.24.04 on Ubuntu 16.04
Plotting difference between two branches of two ttree
Loop over all hits
Storing high-precision values in a TTree
Correlation between variables
Y-axis resdual plot
How to detect XrootD error and protect the output
Likelihood Ratio Test for significance with a TGraphErrors
The data of TTree leaves with red exclamation marks is not visible
PyRoot demo hangs on Mac
Does the order in Filter and Define within rdataframe matter?
Likelihood fit changes signals order
Merging datasets within RDataFrame
I'm trying to fit 3D data into a line
Get the size of a TTReeReaderArray
Low performance merging files with RDataFrame plus multiple cycles
Saving numpy arrays into TTrees
Histogram multiply and division
RDataFrame Inputs for a Just-In-Time Compiled C++ Class
Wildcarding file names with hadd on windows
GetMaximum -1111?
How to define a C++ map
Maximum in the tgraph
Difference between branches
Get TreeNumber of chain in PROOF
"test_with_dictionaries" project
Envelope function
How to draw optimiation of 2D between two variables?
Error: module 'Darwin' does not use additional module map WITH brew & xcode 13.0
Wrong MakeClass?
ImplicitMT Writing issues
Poissonian extended dead time
How to remove or exclude one branch in RDataFrame in python when reading from tuple file?
Compile root with apple M1max
AddLast() {TClonesArray}
Work with complex number in function
Trouble linking against ROOT libraries
Filter data frame using external flags
Cannot find generic objects in workspace
How can I draw a TPolyLine3D on the new web-based RGeomViewer Widget?
Problems with THStack
Inconsistencies of number of entries for each branch
Retrieving 2D histogram fitting parameters
How to find root built-in function?
gSystem->Load() not works in macro
IntegralError give impossible result
Error with TGraph::SetTitle
Can plots be suppressed?
Error in <TRint::HandleTermInput()>: std::bad_alloc caught: std::bad_alloc
Make clean - bug or feature?
Unsupported C++ standard: 11
Macos can't cmake
Multigraph
Unsmooth spline
Problem in accessing individual elements of an array branch through RDataFrame
FitPanel plug in
How to install root?
Issues with combining ROOT files in different order
How to use c++17 with root
How to save RVectors of LorentzVectors in ROOT files?
Failing to build root-6.24.06 and root-6.26.02 on Fedora 36
Problems with changing label
Regression line fit
TGMainFrame problem with close button
Error merging histograms with "similar" x range
How to read the output file properly? specifically FitResults
Unknown Type Error
Parameter issues with TF2 contains 2 same TF1
Erroneous Error messages from TTree::Draw
Where is the package "ROOT" in python2.7
Seg Fault when using TObject::Get()
Continuing the discussion from An unwanted horizontal line is drawn at y=0
About Linking CXX executable error,undefined reference to
ROOT <-> HDF5 interface
Histograms as function parameter and returning their ratio plots
How to do b (Jet.BTag) cut form .root file
Fitting is not working on the triangular peak plot