Runtime error: cling on macosx yosemite 10.10

Hi all,

I am new to this forum. Please forgive me in advance if this is a silly question.

I installed the binary of cling on OS X yosemite and when I run it I get the output below. I also tried compiling cling from git and get the same output. Can anyone please help?

Alessandros-Mac-mini:cling alessandro$ bin/cling

****************** CLING ******************

  • Type C++ code and press enter to run it *
  •         Type .q to exit             *

[cling]$ int a = 10
IncrementalExecutor::executeFunction: symbol ‘_ZN5cling7runtime8internal15setValueNoAllocEPvS2_S2_S2_y’ unresolved while linking function’_Z15__cling_Un1Qu30Pv’!


Not a silly question at all :slight_smile: But I cannot reproduce that. I built with clang --version Apple LLVM version 6.0 (clang-600.0.56) i.e. XCode 6.1.1 and do not see the problem you report. Let me know the details of which compiler you use and how you configure.

Cheers, Axel.

I use the same version:
Alessandros-Mac-mini:~ alessandro$ clang --version
Apple LLVM version 6.0 (clang-600.0.56) (based on LLVM 3.5svn)
Target: x86_64-apple-darwin14.1.0
Thread model: posix
Alessandros-Mac-mini:~ alessandro$

I follow the instructions here: … structions

I use the following configure within the src directory:
./configure --enable-cxx11 --enable-optimized --disable-assertions --prefix=/Applications/

Notice that I get the error even when just installing the binary from here:

curious, works when building with this script: … r/

I am trying to change the configure options in it and will let you know

I tweaked the script with my configure options as earlier.

Removing --enable-optimized removes the error.

Adding --disable-assertions and changing --prefix do not make any difference.

However --enable-optimized is what allows llvm/clang to be built in release mode which is much faster than debug mode.

Is there anything that can be done to get a release build working?


Thanks for finding out! I’ll have a look next week! (Please ping me if you haven’t heard from me by Thursday.)


I also get the same issue described here even on the debug build:
[.L command doesn't work on mac os x 10.9.2?

Here is a youtube video where it was shown it working on OS X:

Looks like Apple has changed things low level in OS X. Several packages that used to compile and work out of the box do not anymore…


any news?


yes news but not the right kind:

I have updated cling to use a new JIT engine, hoping that it might also address the missing symbol issue as a byproduct. Alas it now fails even for our nightly builds and all my efforts to reproduce this have failed so far.

I’ll try to reproduce your config findings next - tomorrow afternoon if things go according to plan!

Cheers, Axel.


Okay - should be fixed. Can you confirm? You could e.g. download the binaries from

Thanks for your report and your persistence! :slight_smile:

Cheers, Axel.

The first one is fixed thanks :slight_smile:

How about loading frameworks? It is pretty crucial on OS X . Is there a quick patch (like for example looking in the path for a directory with path extension “.framework”) ?



Thanks for the confirmation!

Let’s continue the framework discussion at … 264#p82264 - this has nothing to do with the thread here…


I’m also trying to find out how to load frameworks on macOS. I’ve created a post as well cause I couldn’t find anything else.

Please don’t revive 2 years old posts but open a new one. In that new topic, could you please state what you’re trying to do and how it fails? Thanks!