ROOT stopped working after macOS update to Mojave

I think trying the latest master is the only way, sorry. Once all problems are fixed, a new tag release should come up and we will file a PR with homebrew to get a working version into Mojave.

1 Like

So the problem came back again all of sudden :frowning: When I build it, I manage to run it on the build directory, but once installed, I cannot run it anywhere, and gives out this message (the logo just stays on the screen forever):

dyld: Library not loaded: /usr/local/opt/jpeg/lib/libjpeg.9.dylib
  Referenced from: /usr/local/lib/libTIFF.dylib
  Reason: Incompatible library version: libTIFF.dylib requires version 13.0.0 or later, but libJPEG.dylib provides version 11.0.0

Do you still have this issue?

I have Mojave on my mbp and I had the same problem. Here is what I did:

I downloaded the source file and extracted it.

I followed the instructions given in (Building section including source /bin/ to install root. It worked but when I closed and reopened the terminal, it would not detect root, which means I have to source it every time I open the terminal. So I added source <pathname_where_I_Installed>/bin/ to ~/.bash_profile

Now it works like a charm!

@diogopires there is no need to install ROOT; it can be run directly from the build directory.

Yes @ramsmg! I had already done it also and it’s working beautifully now! Thank you!

For future reference, this is what the release notes for Mojave says:

Another useful piece of information is that you can find the SDK’s install directory for the include files using xcrun --show-sdk-path. This is what it shows for me on High Sierra:

$ xcrun --show-sdk-path

I had the same issue. I was able to run ROOT again by moving XCode from /Applications/Utilities/ to /Applications/. Hope this helps.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.