Root crashes while plotting geometry with the "ogl" option

Dear ROOT experts,
I am using root6 in Ubuntu 16.04. I build root with the default build options. It seems that I can not draw the 3D geometry with opengl. For example, I run the script “/tutorial/geom/tank.C”, and will get the segmentation violation error.


That’s weird. I just tried it on may mac. It is fine. Which exact ROOT version are you using ? can you post the errors messages you get ?

It is ROOT 6.12.04. There is no error message actually. Just the segmentation fault message. You can see the screen shot below:

We had an issue with GL in 6.12 at some point. 6.12 is now 6.12/05 … can you try with 6.12/05 ?

Thanks, I will try it soon.

Besides, I have more information about the error. As shown in the previous post, after the segmentation error, a TPad will be popped out and the geometry will be ploted normally in 2D. Then if I manually select view->view with->OpenGL in the menu, the 3D geometry will show up correctly.

Ah ok … weird …

I am still having issues with the latest master:

The post about the JIRA ticket that was mentioned as fixed earlier:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.