Root built failed on macOS Catalina after reinstalling command-line tools

After upgrading to macOS Catalina , ROOT started throwing errors. So, I uninstalled it, then reinstalled command line tools and Xcode.
I tried to reinstall ROOT from Hombrew, and then compile it myself from the binary But it kept giving me the same error

[ 90%] Building CXX object roofit/roofitcore/CMakeFiles/RooFitCore.dir/src/RooWrapperPdf.cxx.o

[ 90%] Building CXX object roofit/roofitcore/CMakeFiles/RooFitCore.dir/src/RooFitLegacy/RooCatTypeLegacy.cxx.o

[ 90%] Building CXX object roofit/roofitcore/CMakeFiles/RooFitCore.dir/src/RooFitLegacy/RooCategorySharedProperties.cxx.o

[ 90%] Building CXX object roofit/roofitcore/CMakeFiles/RooFitCore.dir/src/RooFitLegacy/RooMultiCatIter.cxx.o

[ 90%] Linking CXX shared library …/…/lib/

[ 90%] Built target RooFitCore

make: *** [all] Error 2
I have no idea what might be the issue here …
I would appreciate your help

_ROOT Version:_6.22
Platform: Mac OS Catalina (10.15) On MacBook Air 2018
Compiler: gcc

Hi @aalasfar,
The output you show is not very explicit. First, have you followed the guide ?
Even so, ROOT should be available to mac users via homebrew, did you have any problems with that?

It is not giving me an explicit error message, even looking at the log files
I followed the guide-(I have been working with root for years, I never had such a problem)
Yes, I started with Homebrew and it stoped at the same exact spot.
Root was installed, but once I upgraded to Catalina it did not work anymore. So I reinstalled the command line tools and wanted to reinstall it And that happened .

Hi @aalasfar,
As far as we know ROOT should work with MacOS Catalina. Can you please upload the full output of cmake and the build log? Also see whether this other post can help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.