Redirecting output, root 6

Hi Axel,

I just tried to do

git pull origin v6-04-00

and then configured and run make command both.

But even now I am facing the same old problem. I mean when I run the command twice only then it saves in the log file else it just creates the blank file.

with regards,

Hi Axel,
I have just compiled the latest Pro version (v6-04-02, 14 July 2015, linuxx8664gcc) and also still see the problem. Here is an exmaple; with this macro:

void qc3() {
  cout << "start" << endl;
  TFile *f1 = new TFile("hsimple.root");
  cout << "the end" << endl;

This is what happens:

root [0] .> aa.log
root [1] .x qc3.C
the end
root [2] .>
root [3] .! cat aa.log
root [4] 

So, as I mentioned before, opening a root file is creating problems. Before that line, the output goes to the log file, but not after the TFile line.

  • Daniel


You have tried two releases. The commit is not part of any of these part releases. Please check out v6-04-00-patches. See here for orientation:;a=summary it shows the tags and heads of the branches - you need the head of the 6.04 release branch, thus v6-04-00-patches.

Cheers, Axel.


I am also trying to redirect the output of my code to a txt file.
I am using root version 6.02.00.

I tried this way:

.> out.txt mkdatacards() .>

It doesnt work for me. Has this been solved?


You should install the latest ROOT version, ROOT v6.06/04.

okay, thanks a lot for your reply.

Best regards,


For me its again not working.

My root version is 6.04/02.

root file path: /afs/

And I did this:

root [1] rd51tbgeo->SetScanField(0) root [2] .>g1x_scanOut.log root [3] rd51tbgeo->Scan("g1xcl.ngeoch:g1xcl.geoch:g1xcl.geoX:g1xcl.geoposch:g1xcl.geoposX"); root [4] .> root [5] .q

Finally the file g1x_scanOut.log is creating but its blank. Please let me know if I am doing something wrong.

Also I tried this in root version 6.06/04 but it did not worked.

with regards,