Problems while exiting root .q with canvas

I have a problem while exiting root with .q
If i run a macro creating canvases and i close them before .q, i get the following errors:

2019-09-27 09:58:29.292 root.exe[3044:189346] Fatal error: requested non-existing drawable 147
2019-09-27 09:58:29.292 root.exe[3044:189346] This window not found among allocated/deleted drawables

 *** Break *** segmentation violation
[/usr/lib/system/libsystem_platform.dylib] _sigtramp (no debug info)
[<unknown binary>] (no debug info)
[/Applications/root/lib/] TCanvas::SetDoubleBuffer(int) (no debug info)
[/Applications/root/lib/] TCanvas::Close(char const*) (no debug info)
[/Applications/root/lib/] TCanvas::~TCanvas() (no debug info)
[/Applications/root/lib/] TCanvas::~TCanvas() (no debug info)
[/Applications/root/lib/] TList::Delete(char const*) (no debug info)
[/Applications/root/lib/] TROOT::EndOfProcessCleanups() (no debug info)
[/Applications/root/lib/] TUnixSystem::Exit(int, bool) (no debug info)
[/Applications/root/lib/] TApplication::Terminate(int) (no debug info)
[/Applications/root/lib/] TApplication::ProcessLine(char const*, bool, int*) (no debug info)
[/Applications/root/lib/] TRint::ProcessLineNr(char const*, char const*, int*) (no debug info)
[/Applications/root/lib/] TRint::HandleTermInput() (no debug info)
[/Applications/root/lib/] TUnixSystem::CheckDescriptors() (no debug info)
[/Applications/root/lib/] TMacOSXSystem::DispatchOneEvent(bool) (no debug info)
[/Applications/root/lib/] TSystem::InnerLoop() (no debug info)
[/Applications/root/lib/] TSystem::Run() (no debug info)
[/Applications/root/lib/] TApplication::Run(bool) (no debug info)
[/Applications/root/lib/] TRint::Run(bool) (no debug info)
[/Applications/root/bin/root.exe] main (no debug info)
[/usr/lib/system/libdyld.dylib] start (no debug info)
[<unknown binary>] (no debug info)

i have to do .q again for each closed canvas. Any idea on how to fix this?

Please read tips for efficient and successful posting and posting code

ROOT Version: 6.18/04
Platform: macOS Mojave 10.14.6
Compiler: Not Provided

I just tried on Mac with ROOT 6.19.
I drew an histogram, closed the canvas with the window manager button and typed .q.
All is fine.
Do you have a small reproducer macro ?

analisi.C (4.2 KB) data.txt (32.6 KB)
i use this macro, i just attached also data.txt

Is it supposed to take long to execute ?
Your macro never exit for me…

I only get this:

root [0] .x analisi.C
Info in <TCanvas::Print>: pdf file dispersione.pdf has been created

it should take only 5s to run

so there is something wrong … it enter an endless processing for me.

Ok I managed to make it run changing eff_graph drawing option.
then I type .q … no problem … it exit properly

i downgraded to 6.08/02 and now it works fine…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.