Problem installing ROOT v6.14.06 on macOS Mojave version 10.14.2


I cloned the repo and checked out the latest pro branch v6.14.06 today for installation on my Mac.
I have Xcode version 10.1 with SDK version 10.14.
The standard system python is v2.7.10. I also have python 3 installed v3.7.2 (not via Homebrew or Anaconda but from
I do have some optional dependencies installed via Homebrew e.g. fftw,gsl and pcre

As per usual I’m installing using CMake with a very simple configuration step…

cmake -Droofit=ON -DCMAKE_INSTALL_PREFIX=/Applications/Scientific/cern-root/root-v6-14-06-install ../root-v6-14-06-source/
cmake --build . -- -j4 > build.out 2>&1 &

Everything works fine until around about 74% when I run into the following issue:

Scanning dependencies of target G__Core
[ 74%] Generating G__Core.cxx, ../../lib/libCore.rootmap
In file included from /Applications/Scientific/cern-root/root-v6-14-06-build/include/TString.h:26:
/Applications/Scientific/cern-root/root-v6-14-06-build/include/TMathBase.h:147:18: error: expected unqualified-id
   { return std::signbit(a);  }
/usr/include/math.h:170:5: note: expanded from macro 'signbit'
    ( sizeof(x) == sizeof(float)  ? __inline_signbitf((float)(x))        \
Error: /Applications/Scientific/cern-root/root-v6-14-06-build/core/rootcling_stage1/src/rootcling_stage1: compilation failure (/Applications/Scientific/cern-root/root-v6-14-06-build/lib/libCore6e3bf39ee5_dictUmbrella.h)
make[2]: *** [core/base/G__Core.cxx] Error 1
make[1]: *** [core/base/CMakeFiles/G__Core.dir/all] Error 2
make: *** [all] Error 2

Xcode command line tools are installed.
I’ve tried numerous things to get this working but every time fails at this same point.
Any help to resolve this issue will be much appreciated.

_ROOT Version: 6.14.06
_Platform: macOS Mojave version 10.14.2
_Compiler: clang - Apple LLVM version 10.0.0 (clang-1000.11.45.5)

Could you please try with ROOT 6.14.08? I think earlier versions do not have all necessary fixes for Mojave. This post might also be useful: ROOT stopped working after macOS update to Mojave.

Thanks for the reply @amadio. I didn’t spot the v6.14.08 dev branch earlier, but I’ve found it now.
Unfortunately root v6.14.08 still fails at the same point with the same error. Fails both with cxx11 and cxx14.

Also thanks for sharing the other thread. In relation to the discussion on that thread my homebrew is fully updated and there are no issues when running brew doctor.

Also for completeness if I run xcrun --show-sdk-path my SDKs are located here

Could you then please post your CMakeCache.txt and full build log so that we can try to understand what’s happening (e.g. by attaching or using If you want, you can install ROOT from Homebrew with brew install root as well instead of compiling it yourself.

First time I’m using Pastebin so hope this works.
Here are my relevant files:

I may be on the wrong track, but I’m wondering if CMake is somehow incorrectly using the c++ include files within /usr/include as opposed to in the correct SDK path? For some other older software I installed Xcode’s workaround package (/Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg) as per the release notes. However, I guess this was meant to be addressed in root v6.14.08 right?

Once again, any help much appreciate. I like Homebrew… but not for ROOT. I have software that builds against root and run into issues with Homebrew ROOT versions in the past… but that’s a whole different discussion not for this thread :slight_smile:

If you are having problems with root from homebrew, try the MacPorts version instead. In my opinion, Macports is anyway a superior package management system, so there are also other advantages to using it :wink:

sudo port install root6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.