Mac Sierra installation problems with ROOT 5.34.36

Dear ROOTers,

I’m trying to install ROOT 5.34.36 on my macOS Sierra version 10.12.6 and I’m having this issue after trying to build it this way:

mkdir build && cd build

cmake .. -Dminuit2=ON -Dgdml=ON -Dfftw3=ON -DFFTW_DIR=/Users/vanoel/snoplus/snoing/install/fftw-3.3.4/ -DGSL_CONFIG_EXECUTABLE=/Users/vanoel/snoplus/snoing/install/gsl-1.16/bin/gsl-config 

cmake --build .

the file exists in the directory which is


and this is the error I got:

/Users/vanoel/snoplus/snoing/root-5.34.36/math/mathmore/src/GSLFunctionWrapper.h:34:10: fatal error: 'gsl/gsl_math.h' file not found
#include "gsl/gsl_math.h"

Any ideas?

Is that non-standard directory in the include path? Here is the info for gcc from the man pages:

Well but indeed, GSL_CONFIG_EXECUTABLE should have taken care of that. @mato - any idea what’s happening here?

Is your build directory inside your source directory?

I most definitely don’t have gsl-config, but I do have the gsl libraries installed in a typical location. Also, if the PATH is also not set correctly then I doubt that CMake will find this app and it is not cleared that @lawlieto even installed it for that matter.

@lawlieto, do you have the file /Users/vanoel/snoplus/snoing/install/gsl-1.16/bin/gsl-config?

EDIT: I thought we were disucssing ROOT 6 here. The following may not apply to ROOT 5.34.36

There should be a message if GSL wasn’t found. @lawlieto I think it would be useful if you posted your CMakeCache.txt and the full output of CMake.

Here is the check for GSL from cmake/modules/SearchInstalledSoftware.cmake (ROOT 6.10.04):

if(mathmore OR builtin_gsl)
  message(STATUS "Looking for GSL")
  if(NOT builtin_gsl)
    find_package(GSL 1.10)
        message(FATAL_ERROR "GSL package not found and 'mathmore' component if required ('fail-on-missing' enabled). "
                            "Alternatively, you can enable the option 'builtin_gsl' to build the GSL libraries internally.")
        message(STATUS "GSL not found. Set variable GSL_DIR to point to your GSL installation")
        message(STATUS "               Alternatively, you can also enable the option 'builtin_gsl' to build the GSL libraries internally'")
        message(STATUS "               For the time being switching OFF 'mathmore' option")
        set(mathmore OFF CACHE BOOL "" FORCE)

Thank you for your replies.

  • The build dir was contained within the src dir, after deleting the src directory and unpacking again, and building out of directory the same error occured
  • /Users/vanoel/snoplus/snoing/install/gsl-1.16/bin/gsl-config exists and returns the correct paths
  • I’ve also tried specifying -DGSL_DIR with the gsl installation, the same error occurs
  • CMAKE doesn’t report an error after looking for GSL
-- Looking for GSL
-- Found GSL: /usr/local/include (found suitable version "1.16", minimum required is "1.10")

Using the builtin gsl for now and that works. Full log of failed build attached below:

log.txt (2.9 KB)

CMakeCache.txt (50.6 KB)

Try the old method … make sure that you start with a “fresh” source code (try “./configure --help” in order to see all available options):

./configure --enable-soversion --all > configure.out.txt 2>&1
make > make.out.txt 2>&1

Note that “5.34.36” is really old so, you’d better use the head of the “v5-34-00-patches” branch (for ROOT 5):

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.