Issue: Error bars always visible for empty bins with kPoisson enabled

I have an issue with drawing histograms. I’m using kPoisson error option so my histogram setup looks like this:


I’m drawing the plot then with PEsame flag. The issue is, that error bars are still visible, even when I use only the E flag (I double checked, there is no E0 anywhere). The issue goes away if I do not set the kPoisson option.


Empty bins have also a 68% confidence interval and this is what is displayed. However, I agree, it is sometimes not nice to display them with so large error bars. We should re-add the option E0 to suppress their display or add a different option like TH1:kPoisson0


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.