Installing Root v6 on Debian Wheezy

First of all, I am a novice in installing root. I am definitely not an expert and am thankful for anyone who is willing to help.

Right now, I am running root v5.34 and I need to install root v6 without destroying my current version of root. I am running Debian Wheezy. I have downloaded the source file “root_v6.06.06.source.tar.gz” from the root page ( and unpacked in a sub-directory called root6 in my personal account home directory. I also made another directory root6 in usr/local/root6 because I have admin privileges. Going into the directory “root6” in my personal account home direcotry, I ran:

./configure --prefix=/usr/local/root6 --etcdir=/usr/local/root6/etc --enable-soversion --enable-shared --enable-opengl --with-gsl-incdir=/usr/include --with-gsl-libdir=/usr/lib

Since there was nothing to configure in that directory, an error occurred. I then went into the root-6.06.06 directory (the directory made from unpacking the .tar.gz file) and ran the same command.
I then ran the make command. 45 minutes later, an error resulted. I tried to fix it and the error tragically scrolled off the terminal’s view. I ran make clean. Then make, and the following error, which I believe to be the same error from the first time, resulted:

In function cling::Interpreter::GenerateAutoloadingMap(llvm::StringRef, llvm::StringRef, bool, bool)': Interpreter.cpp:(.text+0x4584): undefined reference tocling::Interpreter::forwardDeclare(cling::Transaction&, clang::Sema&, llvm::raw_ostream&, bool, llvm::raw_ostream*, bool (*)(clang::PresumedLoc const&)) const::{default arg#1}::{lambda(clang::PresumedLoc const&)#1}::_FUN(clang::PresumedLoc const&)'
collect2: error: ld returned 1 exit status
make: *** [core/utils/src/rootcling_tmp] Error 1

Had no errors happened, I planned on running “sudo make install” and then running “sudo idconfig.” I was then going to edit ~/.bashrc to point to the directories associated with the root v6 that would have just been installed.

I can be wrong but I remember statements that you need gcc 4.8.x or newer for ROOT 6 (despite the fact that the official ROOT 6 web page claims “gcc > 4.7.x”.)

Is it possible/suggested to install gcc 4.8 on Wheezy?

I installed 4.9 in wheezy, and later built ROOT, see: