Installing Root on Mac Problems not Configuring

Please read tips for efficient and successful posting and posting code

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

Hi so I was trying to set up root on my mac and I keep getting this error when using cmake to configure.

– Configuring incomplete, errors occurred!
See also “/Users/conor/builddir/CMakeFiles/CMakeOutput.log”.
MacBook-Pro:builddir conor$ cmake …/root
CMake Error at CMakeLists.txt:12 (find_package):
By not providing “FindROOT.cmake” in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by “ROOT”, but
CMake did not find one.

Could not find a package configuration file provided by “ROOT” with any of
the following names:


Add the installation prefix of “ROOT” to CMAKE_PREFIX_PATH or set
“ROOT_DIR” to a directory containing one of the above files. If “ROOT”
provides a separate development package or SDK, be sure it has been

Not sure how to fix this.

What did you do exactly? What did you download, and what are the different steps you executed?

So I downloaded Cmake andUploading: root_v6.19.02.macosx64-10.15-clang110.tar.gz… I tried following the install directions from the file.

3.1. Location independent build:

You want to install in a generic directory, depending on environment

  1. Get the sources of the latest ROOT (see above)

  2. Type the build commands:
    cmake …/root

it is at the point of using Cmake that the issues happened. I did have to move the CMakelists.txt file out of the tutorial folder and into the main folder in order to get to even run.

You downloaded the binary version of ROOT. So there is no need to build it…

So I just download it. Is there anything I need to do to be able to open root?

You need to source (which is in the bin directory of root) to get ROOT in your PATH, then you can simply start root

Almost there another error popped up. This is what I saw after attempt to start root after trying to start root.

MacBook-Pro:bin conor$ source

MacBook-Pro:bin conor$ root

ERROR in cling::CIFactory::createCI(): cannot extract standard library include paths!


/Library/Developer/CommandLineTools/usr/bin/c++ -O2 -DNDEBUG -xc++ -E -v /dev/null 2>&1 | sed -n -e ‘/^.include/,${’ -e ‘/^ /.*++/p’ -e ‘}’

Results was:

With exit code 0

warning: no such sysroot directory: ‘/Library/Developer/CommandLineTools/SDKs/MacOSX10.15.sdk’

input_line_1:1:10: fatal error: ‘new’ file not found



input_line_3:37:10: fatal error: ‘string’ file not found



*** Break *** segmentation violation

[/usr/lib/system/libsystem_platform.dylib] _sigtramp (no debug info)

[] (no debug info)

[/Users/conor/root/lib/] ROOT::TMetaUtils::TNormalizedCtxt::TNormalizedCtxt(cling::LookupHelper const&) (no debug info)

[/Users/conor/root/lib/] TCling::TCling(char const*, char const*, char const* const*) (no debug info)

[/Users/conor/root/lib/] CreateInterpreter (no debug info)

[/Users/conor/root/lib/] TROOT::InitInterpreter() (no debug info)

[/Users/conor/root/lib/] ROOT::Internal::GetROOT2() (no debug info)

[/Users/conor/root/lib/] TApplication::TApplication(char const*, int*, char**, void*, int) (no debug info)

[/Users/conor/root/lib/] TRint::TRint(char const*, int*, char**, void*, int, bool) (no debug info)

[/Users/conor/root/bin/root.exe] main (no debug info)

[/usr/lib/system/libdyld.dylib] start (no debug info)

[] (no debug info)

Maybe searching the forum might help? For example:

Thank you for your help. I will take a look.

The issue has been solved. I just needed to install xcode command line tools. Thank you so very much for your help.

1 Like

You’re very welcome!