Installation issues of new version root-6.06.00

As I was trying to install root-6.06.00 on my Fedora 21 with gc version 4.9 and 32bit build using the following installation method:
[ul]wget root.cern.ch/download/root_v6.0 … rce.tar.gz
tar zxvf root_v6.06.00.source.tar.gz
export ROOTSYS=/home/…/pythia_root/root-6.06.00
cd root-6.06.00
./configure --enable-soversion --all --build=debug --with-pythia8-incdir=$PYTHIA8/include --with-pythia8-libdir=$PYTHIA8/lib > configure.out.txt 2>&1
gmake > make.out.txt 2>&1[/ul]

I am receiving the following error message after doing: gmake

[quote]In file included from /home/…/pythia_root/root-6.06.00/math/mathcore/src/MixMaxEngine.cxx:19:0:
/home/…/pythia_root/root-6.06.00/math/mathcore/src/mixmax.h:98:19: error: ‘__uint128_t’ was not declared in this scope
myuint mod128(__uint128_t s);
^
Makefile:655: recipe for target ‘math/mathcore/src/MixMaxEngine.o’ failed
gmake: *** [math/mathcore/src/MixMaxEngine.o] Error 1[/quote]

As I continue ignoring the error towards gmake install , it becomes obvious that lots of error would accompany which will cause the source not to be installed properly. I have already uninstalled the older version. So, what would be the cause? I am wondering if I am choosing a wrong version not being compatible with my system or missing other important notes in the above commands. Your help is greatly appreciated.

Hi,


Cheers, Bertrand.

Hi,

ROOT’s master and head of v6-06-00-patches now work on 32bit. We are planning a patch release 6.06.02 including this.

Cheers, Axel.

Thanks bellenot,
I was trying to avoid Cmake method in order to have an “in-place” installation of root which does not go into my /usr/local or …and that I can compile and run the code as a C code from command line. Would that be possible?
something like the following command that I used to invoke for my older version of root?

And thanks dear Axel, I can’t wait to see that release.

Sincerely,

Hi,

Sure, you can use the CMAKE_INSTALL_PREFIX variable. E.g.:

[quote=“ashur”]something like the following command that I used to invoke for my older version of root?

[/quote]
This is independent of CMake

Cheers, Bertrand.

Hi Bertrand,
Somehow I thought, I need to do both of the following lines of command:

I did the first but noticed that I should have done the second instead for my desired method.
Do you know if I can undo the first command?

Plus I received the following error message at the end of first command:

[quote]Install the project…
– Install configuration: "RelWithDebInfo"
CMake Error at cmake_install.cmake:36 (file):
file cannot create directory: /usr/local/tutorials. Maybe need
administrative privileges.

Makefile:66: recipe for target ‘install’ failed
gmake: *** [install] Error 1
[/quote]

Thanks,

The resolution to my second concern (error message coming form first command) is found here
http://stackoverflow.com/questions/34886877/cmake-error-at-cmake-install-cmake31-file-file-cannot-create-directory-usr
So by disabling “roottess” option during cmake, we can resolve the issue. However, I am still confused as whether both commands should be entered or just the second one (related to my preference).

Thanks,

I solved the problem except that now after

I am receiving this error message:

[quote]CMake Error at cint/ROOT/cmake_install.cmake:42 (file):
file INSTALL cannot find
"/home/…/root5.34.32/lib/libvectorDict.so".
Call Stack (most recent call first):
cint/cmake_install.cmake:38 (include)
cmake_install.cmake:157 (include)[/quote]

What do you guys think?
I ignored the error and proceeded further and it seems that it works now. But, I did this only for v5.34.32.
I think I need to wait for Axel to let me know how long should I wait for 06.02 or …?

Thanks,

Hi,

No need to wait for me:

mkdir root
cd root
git clone http://root.cern.ch/git/root.git src
cd src
git checkout v6-06-00-patches
cd ..
mkdir build
cd build
cmake ../src
make -j8
. bin/thisroot.sh
root -l -b

Repeat the last two as often as you like.

Cheers, Axel

Thanks Axel for taking your time and being kind to put down all lines.

Sincerely,