Installation error on windows

I’m trying to install root for windows but i’m having some issues.

when I input “make -j4” it always stops at

[ 75%] Built target CLING
[ 75%] Built target clad
[ 75%] Built target LLVMRES
CMake Error at XROOTD-stamp/XROOTD-download-Release.cmake:49 (message):
Command failed: 1

‘/usr/bin/cmake’ ‘-Dmake=’ ‘-Dconfig=’ ‘-P’ ‘/home/mario/root-6.26.02/buildroot/builtins/xrootd/XROOTD-prefix/src/XROOTD-stamp/XROOTD-download-Release-impl.cmake’

See also


make[2]: *** [builtins/xrootd/CMakeFiles/XROOTD.dir/build.make:91: builtins/xrootd/XROOTD-prefix/src/XROOTD-stamp/XROOTD-download] Error 1
make[1]: *** [CMakeFiles/Makefile2:8712: builtins/xrootd/CMakeFiles/XROOTD.dir/all] Error 2
make: *** [Makefile:152: all] Error 2

Does anybody know how to fix the problem?

ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided

Take the “head” of the v6-26-00-patches branch (and remember to delete your build directory).

Thank you very much, but i’m not very experienced in this: how do i recognize the head of the patches branch and what do i do with it? Also by “delete your build directory” you mean I have to delete the “build root folder” ? Sorry for the basic questions but i never do this kind of stuff

Try something like this:

rm -rf root_src root_build root_install
git clone --branch v6-26-00-patches --depth=1 root_src
mkdir root_build
cd root_build
cmake -Dall="ON" -DCMAKE_INSTALL_PREFIX=../root_install ../root_src
cmake --build . -- install -j4

It totally worked; thank you very much. One last question then it should be over: on the youtube tutorial i’m watching the guy uses the command:
. root-6.26.02-install/bin/
but on my computer it says that there’s no such directory; where do i find the right directory?

source /full/path/to/your/root_install/bin/

Nope, it still doesn’t work, the “” file was put in config so the path is this:
also, do i have to change all the backslashes into normal slashes?

Looking at the first post, I guess it would be something like:
source /home/mario/.../root_install/bin/