I want to install ROOT in windows 10 for the use in python 3.9

_ROOT Version: root v6.26.10
Platform: Windows 10 Visual studio code

Welcome to the ROOT forum.

Does the ROOT install page help? If not, I am sure @bellenot can help you.

I followed the steps. but not working

Can you give more details?

sure I am trying to unpickle jet.pickle data set in Jupyter Notebook using following code

import pickle

with open('jet.pickle', 'rb') as f:
    data = pickle.load(f)

the error is ModuleNotFoundError: No module named 'libPyROOT'

I tried Installing ROOT using WSL, Also tried using zip and exe installer for windows 10
what could be the reason ?

OK, let’s start from the beginning. Did you manage to install and start root from the command prompt? (we’ll see the Jupyter Notebook problem later)

The “libPyROOT” was provided/used by older ROOT versions (up to 6.20).
You could build newer ROOT versions (from 6.22) this way, but you would need to specify “-Dpyroot_legacy=ON”.

I faced error. of extracting directories for WSL,
Then I Tried following steps

  1. Download the ROOT binary distribution for Windows from the CERN website.
  2. Extract the contents of the downloaded archive to a directory of your choice.
  3. Create a system environment variable named “ROOTSYS” and set its value to the directory where you extracted the ROOT files.
  4. Add the bin directory located inside the ROOTSYS directory to the system’s PATH environment variable.
  5. Open a new command prompt or terminal and test the ROOT installation by running the command “root.exe” .

Okay, Can you suggest clear steps?

First you must decide if you want to install ROOT in WSL or on native Windows. For WSL, see for example this topic. For Windows, simply follow the instructions from the download page

I want to install it on native windows, I tried installing the .exe file and setting up environment variables and it did not work.

What didn’t work? The easiest way is to install a binary, and then call (for example) C:\root\bin\thisroot.bat from a x86 Native Tools Command Prompt for VS2022 for 32 bit, or from a x64 Native Tools Command Prompt for VS2022 for 64 bit. So what did you do exactly?

I have installed root and working fine…but still encountering error while using in Jupyter notebook or google colab.

It seems your “jet.pickle” file was created with an older ROOT version, so it needs the “legacy” Python bindings of ROOT.

Actually, I would expect that you needed a ROOT version “equal” or “very close” to the one used to create this file (otherwise, mysterious “StreamerInfo” / “TBufferFile::CheckByteCount” errors can appear).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.