Enabling pythia6 in cmake build


i am trying to install root using the cmake build , but i am unable to get pythia6 to be enabled (have tried ccmake and -Dpythia6=ON ) .
to use pythia6 with make, i had to use --with-pythia6-uscore=SINGLE option, but i do not know how to specify it for cmake. could somebody please explain what this option actually means and how to use it with cmake ?



This is a part that I didn’t fully understand in the standard configure. What is now there is very naive and simple. If you provide -Dpythia6=ON it will look for the libpythia6 library in the standard places and $PYTHIA6_DIR/lib and the library should include the symbol pythia6_common_address. Nothing was done for pythia6_uscore.
Can I ask you how did you provide the actual fortran pythia library? Did you load it explicitly?

i did not provide any paths (because i assumed root will install pythia6 itself), although i have the same problem in the normal makefile build’s configure, it enables pythia6 only when the uscore option is enabled .but i have tried manually getting pythia6 off the root ftp and making it and putting the libPythia6.so is LD_LIBRARY_PATH, which configure detects normally even without the uscore option . but this caused failures related to pythia in aliroot, so i had to revert to using the uscore option. :frowning:

The following instructions did work for me.

  • Build and Install
  • Setup environment
  • Run the example

Can you try to reproduce them in your system and provide feedback?