Cannot start xproofd

Dear All

I encountered some troubles while starting xproofd

It seems that some important libraries are missing

any suggestion?

Il looks like the XRootD libs are not in the LD_LIBRARY_PATH.
Can you retry after executing

$ $ROOTSYS/bin/ <dir-with-xrootd>

where is such that /lib contains .

G Ganis


Thank you for your kind reply and assistance! Would you mind elaborating more on ?

The version of my ROOT package is ver.6 (the version is 5.34 on other nodes of the clusters).

Besides installation of ROOT packages, do I need to install/configure other things in order to obtain



Dear Johnny,

xproofd requires the XrootD package installed.
Now, because of significant changes in packaging in Xrootd libs between v3 and v4, the situation is a bit complicated, especially if you use downloaded binaries.

So, the first thing to know is if you are building ROOT by yourself. If not, you have to find out a) if the downloaded binaries have been built with XRootD enabled and, if yes, b) which version of XRootD.
The answer to question a) is yes if you have under $ROOTSYS/lib .
If this is the case, can you run

$ ldd $ROOTSYS/

and post the result?
This will give indications on the version of XRootD (3 or 4) to be used.

G Ganis

Thank you for your reply, Ganis !

I downloaded and unzipped the ROOT package “root_v6.04.02.Linux-ubuntu14-x86_64-gcc4.8.tar.gz” from CERN and sourced it. That’s how I installed the ROOT package.

I don’t think I have the XROOTd installed, so I downloaded and unzipped “xrootd-4.2.3.tar.gz”.
I don’t think how to use it.

Would you mind elaborating more on this?


Dear Johnny,

I have tried the binary that you downloaded on my Ubuntu 14.04 machine and found that it requires xrootd 3.3.6 .
XRootD does not provide pre-builds for Ubuntu (
It is, however, quite easy and fast to install. You can either follow the instructions on the XRootD page or use the script; … ads/master

in this way:

$ chmod a+x
$ sudo ./  -v 3.3.6 /opt/xrootd

This will install under /opt/xrootd/xrootd-3.3.6 .
Once this is done, just run

$ $ROOTSYS/bin/ /opt/xrootd/xrootd-3.3.6

and you should be done.

Please try and let me know.

G Ganis


I tried a different approach to solve the issues in recent days. I tried to run the dedicated script

“” and ended up with something like this. It seems that there is something wrong with script

that the xrootd cannot be installed.

Have you tried running this script to install and configure xrootd/xproofd before ?

Best Johnny


The script is used regularly to install xrootd.

I wrote you to run it like this

$ sudo ./  -v 3.3.6 /opt/xrootd

version 3.2.7

  • does not exist anymore
  • is not what you need.
    You can change of course the destination directory /opt/xrootd to any place where you can write.

G Ganis


If the executable of xproofd is missing, how can I build an executable of it ?

The binary that you pointed me contains the executable under ‘bin’ .
Otherwise you need to rebuild ROOT; currently there is no way to add a non-built component to an existing ROOT binary installation.

G Ganis


Many Thanks !

I managed to install xrootd and xproofd and… mostly importantly, successfully started PoD server !

Thanks for your kind assistance all along the way!