Building failed after upgrade to Mac OS 13.3.1

_ROOT Version:6.28.00 6.28.02
_Platform:mac OS 13.3.1

building root failed after upgrade from macOS 13.3 to 13.3.1
errors below

[ 83%] Built target rootcling_stage1
[ 83%] Built target MetaCling
[ 83%] Generating G__Core.cxx, ../lib/libCore.rootmap
[ 83%] Linking CXX shared library ../../../lib/
In file included from input_line_7:144:
/Users/cx/software/ROOT/build/include/TClassEdit.h:29:10: fatal error: 'cxxabi.h' file not found
#include <cxxabi.h>
[ 83%] Built target Cling
Error: /Users/cx/software/ROOT/build/core/rootcling_stage1/src/rootcling_stage1: compilation failure (/Users/cx/software/ROOT/build/lib/libCoref3fceb25fd_dictUmbrella.h)
make[2]: *** [core/G__Core.cxx] Error 1
make[1]: *** [core/CMakeFiles/G__Core.dir/all] Error 2

however I found cxxabi.h on /Library/Developer/CommandLineTools


it should be a Mac problem, not sure why.

@Axel It seems there is no “./SDKs/MacOSX13.3.sdk/usr/include/cxxabi.h”.

copy a cxxabi.h into sdk
It should be somewhere not in ./SDKs/MacOSX13.3.sdk

try to add cxxabi.h,__cxxabi_config.h in CPLUS_INLCUDE_PATH and building OK.

Please don’t copy files into the macOS SDK, this will certainly cause a mess!

The current nightly builds of master and the 6.28 release branch should have this fixed. I will create a release in about two weeks.

Alternatively, if you really need to build from source, delete the existing build directory, run cmake again and build and it should work.

Cheers, Axel

only try to add cxxabi.h ,__cxxabi_config.h in CPLUS_INLCUDE_PATH
building fine.
but there is something wrong with Mac OS 13.3.1 !

root[0000]:> new TBrowser

 *** Break *** segmentation violation
root.exe(47274,0x1fc33db40) malloc: Heap corruption detected, free list is damaged at 0x600003b6c1f0
*** Incorrect guard value: 468157792370
root.exe(47274,0x1fc33db40) malloc: *** set a breakpoint in malloc_error_break to debug

building fine now but has another serious bugs!
mv to


Has your problem been solved yet? I recently upgraded my MacOs to 13.3.1 and had the same error while building the latest root version (v6.28). The

In file included from :4:
/usr/local/root/root-build/include/TClassEdit.h:29:10: fatal error: ‘cxxabi.h’ file not found
#include <cxxabi.h>
In file included from input_line_3:2:
/usr/local/root/root-build/include/Rtypes.h:195:10: fatal error: could not build module ‘ROOT_Foundation_Stage1_NoRTTI’
#include “TIsAProxy.h”

Error: Error loading the default rootcling header files.

Please let me know if anyone has some solution to fix it.

Thank you
1 Like

You will currently need to build master or v6-28-00-patches, the latest release does not contain the required fixes yet.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.